Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I did a fresh install of 13.04 on my Dell Precision M6500. I was previously running 12.04 LTS. My laptop has an ATI Mobility Radeon HD 5870 adapter and I'm using the open source driver.

Plugging in an external display on boot enables mirroring which is nice by default. Since I want to run this off to extend my display, I use the display adapter utility to uncheck mirror and apply. about 50% of the time, I get a crash of Unity and/or Compiz.

I lose the launcher and the title bars on my window and the ability to change windows. Pretty scary stuff since 12.04 LTD didn't have this problem. To recover my apps, I do a Ctrl-Alt-F1 to get to a terminal, log in, cross my fingers, and run:

unity --replace
or
DISPLAY=:0 unity --replace

I then do a Ctrl-Alt-F7 and pray that my apps respond again so that I can close them and restart. If I don't get my apps to respond, I'll try this from a console terminal:

DISPLAY=:0 compiz --replace

This will sometimes get my apps back, albeit without Unity. At least I can close them gently. If I can't get my apps back, I have to close the apps I can and restart via Ctrl-Alt-Del and home that my hidden applications panic.

I will also get Unity / Compiz crashes when using Shutter and sometimes when accessing the Stormcloud weather application.

I tried the proprietary ATI drivers, and they were worse, with Mirroring on by default and attempting to unmirror via the ATI utility or the Ubuntu display manager not working either. I was also getting the virtual display adapter resolution error and I wasn't ready to have manually maintained a xorg.conf file.

Here are some display particulars for my system:

jim@jim-Precision-M6500:~$ lspci -nnk | grep -i vga -A3
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Broadway XT [Mobility Radeon HD 5870] [1002:68a0]
Subsystem: Dell FirePro M7820 [1028:12ef]
Kernel driver in use: radeon
01:00.1 Audio device [0403]: Advanced Micro Devices [AMD] nee ATI Juniper HDMI Audio [Radeon HD 5700 Series] [1002:aa58]
jim@jim-Precision-M6500:~$ /usr/lib/nux/unity_support_test -p
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD JUNIPER
OpenGL version string: 3.0 Mesa 9.1.1

Not software rendered: yes
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: yes
GL vertex buffer object: yes
GL framebuffer object: yes
GL version is 1.4+: yes


Unity 3D supported: yes

So I'm quite frustrated at this point and the 3 to 5 Unity crashes a day are unproductive.

Any advice out there?

Thanks

share|improve this question

closed as off-topic by bain, chaskes, Eliah Kagan, Eric Carvalho, Luis Alvarado Aug 4 at 18:17

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – chaskes, Eliah Kagan, Luis Alvarado
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Did you ever solve this? I have what I believe might be a related issue. –  Andre May 23 '13 at 1:19

2 Answers 2

This is for Ubuntu 10.10 but this might help. http://milindshakya.tumblr.com/post/4952304640/setting-up-external-monitor-as-the-primary-monitor-in

share|improve this answer
1  
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  fossfreedom May 4 '13 at 18:57
    
Thanks Thunder, but I want my laptop display to be my primary. I just can't have Unity & Compiz crash using dual displays. When using my primary, this crash never happens. –  user153757 May 23 '13 at 14:36

I had a very similar problem with my computer setup. I installed 13.04 onto my desktop where I am using two monitors and similar to your situation when I tried to deselect the mirror display option my computer would lose the launcher and the title bars on windows and the ability to change windows.

Here was my fix. (sorry i do not have images, I do not know how yet) 1. Go to software updater and click on "settings" then select the "additional drivers" tab. Make sure the correct driver in selected...On my computer it is "X.org X server..." driver.

  1. Go to "Ubuntu Software Center" type "xorg" in the search bar and install the "NVidia binary X.Org driver"

  2. Go back to display and deselect the mirror option and it should work.

Additionally when I was using 12.04 I followed step 1 above but for step 2 would have to install the "ATI binary X.Org driver" found by typing "ATI" into the softwear center and then step 3. would to search applications by typing "amd" and tweaking the amd catalyst settings.

I hope that this helps, it worked for me.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.