Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

rdesktop works great to login to my Windows 7 Enterprise system and passes the ActivKey USB Smart card with no problems. Once the session is started, I can login to VPN and authenticate to websites on the remote system perfectly. Unfortunately I can only get 16 color depth with rdesktop and would like to leverage higher color depths since I use this remote system all day long.

Remmina client and freerdp from the command line both work well at the higher color depth but Reminna doesn't have an option passing the smart card and freerdp doesn't work when I pass it with rdpdr "scard" option.

Any ideas on what I am doing wrong or is there another tool that might work better?

This works:

$ rdesktop -z -a 24 -T myserver -d DOMAIN -u username -x l -P -f -r sound:remote -r scard:"ActivIdentity Activkey_Sim 00 00" xxx.xxx.xxx.xxx

This connects okay but doesn't pass the smart card:

$ $ xfreerdp -d DOMAIN -u username -f --plugin rdpdr --data scard:"ActivIdentity Activkey_Sim 00 00" -- x.x.x.x
loading plugin rdpdr
connected to x.x.x.x:3389
Password: 
freerdp_load_library_symbol: failed to open /usr/lib/x86_64-linux-gnu/freerdp/scard.so: /usr/lib/x86_64-linux-gnu/freerdp/scard.so: cannot open shared object file: No such file or directory
freerdp_load_plugin: failed to load scard/DeviceServiceEntry

I am using:

Ubuntu 13.04
remmina 1.0.0-4ubuntu2
freerdp-x11 1.0.1-2ubuntu1
rdesktop 1.7.1-1ubuntu4
pcsc-tools 1.4.21-1
coolkey 1.1.0-12
libccid 1.4.9-1
pcscd 1.8.6-3ubuntu1b1

Thanks for any assistance.

Henry

share|improve this question
    
Final working command for fullscreen, 32bpp, smooth fonts, remote sound, local caching : $ rdesktop -z -x 0x80 -P -f -a 32 -K -T Notebook -d DOMAIN -u username -r clipboard:PRIMARYCLIPBOARD -r sound:remote -r scard:"ActivIdentity Activkey_Sim 00 00" x.x.x.x –  Henry Apr 30 '13 at 15:28

2 Answers 2

I found this issue. https://github.com/FreeRDP/FreeRDP/issues/792

I guess smart card is not included with default ubuntu RDP package. When I compiled from source using

cmake -DWITH_PCSC=ON -DWITH_SSE2=ON .

It works.

share|improve this answer

You can use 32bpp with Windows 7 using rdesktop, also make sure that client settings of RDP-Tcp allows the color depth.

share|improve this answer
    
Great solution. Thanks. I thought 24bpp was max. 24bpp is only supported on XP. As you say, 32bpp works well and is the default for Win 7. –  Henry Apr 30 '13 at 14:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.