Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I already posted this, but I found out a few new things, so I hope it is ok if I just edit my old post. I am aware that this problem has been discussed several times. However, all the fixes I could find here and elsewhere in the web didn't work for me:

I thought before that I had forgotten my password, which was weird because I felt pretty sure about it. My new theory is that I upgraded from 11.04 to 12.04, and I forgot about it at first because this happened sometime ago and I haven't used Ubuntu since then. I have read in other questions that this can hamper with the password recognition. Then I changed the password via the recovery mode, and perhaps I did something bad there, although I followed the fairly straightforward instructions I found here. Perhaps the problem was that I used mount -o rw,remount / to remount the file system with read and write rights.

EDIT: I just realized, that for some reason I cannot even access my /home folder. When I log in as root in the recovery mode or start the shell via Strg+Alt+F3 at the login screen and I try to cd to that directory, I only see two entries under /home/stephen: Access-your-private-data.desktop README.txt. The README tells me that my private data have been 'unmounted' to protect them. When I try to ecryptfs-mount-private, it asks for a key that I don't have, my user password does not work. Perhaps that is the reason why I could not remove the .Xauthority file or why other things I tried didn't work.

What is going on here?

What I tried:

  • I can log in to the shell at the start screen and also see that my new password works
  • I then tried chown stephen:stephen .Xauthority. It says the file cannot be found
  • I tried ls -ld /tmp, all looked as it should according to a previous post I found here
  • I tried dpkg-reconfigure lightdm, and tried lightdm and gdm
  • When I use gdm it shows the background picture for a while, then says 'Could not update ICEauthority file /home/stephen/.ICEauthority and returns to the login screen again
  • I removed and reinstalled lightdm and gdm
  • I tried apt-get update and upgrade. With update I got some error messages: Some index files failed to download. They have been ignored or old ones were used instead. I think I had these messages before but never got around to fixing it.

    Could that have caused the problem?

  • I also tried apt-get install nvidia-current, also no luck
  • I just tried to start in failsave graphics mode (or similar) from the recovery mode. The system told me that my drive had to be remounted and then nothing happened, and I had to abort. The same happened when I tried to start dpkg from the recovery mode, which I had hoped could repair potentially broken packages.
  • yes, I don't know what I am doing! But I am trying!

Is there anything else I can do?

I need to finish a project for my studies and I need access to Ubuntu and especially my matlab version on that laptop urgently.

Maybe it is also important that I run windows and Ubuntu in parallel on the laptop.

share|improve this question
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.