Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've had the same issue with the previous version but I was able to fix it. I've just updated to ubuntu 13.04 and now have the same problem again. Basically, I cannot install the guest additions from the desktop because the compiz application fails and I just see the background, there is no way for me to autorun the vbox additions. So I need to open the command shell from GRUB, mount the cd and run the Linux Additions from there. Everything is fine for step one and two. However, when I try

sh ./

I receive an error message regarding Read-only file system.

mkdir: cannot create directory `/tmp/selfgz741': Read-only file system
Cannot create target directory /tmp/selfgz741

Here is the permissions for the /tmp folder:

drwxrwxrwt  root  root  tmp

I'm wondering what is required so that I can write in the /tmp folder. Also, when I'm in the console, i'm connected as root@virtualbox.


share|improve this question

Open up a terminal and cd to the directory where is located

example: cd /media/user1/VBOXADDITIONS_4.2.12_84980/

And run the command below

sudo sh ./
share|improve this answer
Worked foe me in lubuntu 13.04 – EGHDK Jun 4 '13 at 9:18

Don't open the shell from GRUB. Boot Ubuntu normally. Then, press Ctrl+Alt+F1 and login to the 1st virtual terminal. Next, install the guest additions. Finally, reboot with "sudo reboot".

share|improve this answer

The root shell we access from Grub will mount all filesystems as read only. To enable read/write access (including to the /tmp directory) while installing Guest Additions we need to enable networking before we drop to the root shell prompt:

enter image description here

share|improve this answer

You need to change the permissions of the /tmp directory. Open your terminal and type:

sudo chown <your_username>:<your_group> /tmp

Then try again. Hope that helps.

share|improve this answer
Is there some way to see which group I belong to? Is there a default group my user should be part of? – SomeLinuxNoob Apr 29 '13 at 14:38… – Raja Apr 29 '13 at 14:40
I can see the groups my user belongs to but is there one group I should choose in particular? I've tried with group adm but I still have the directory problem when I run the command. – SomeLinuxNoob Apr 29 '13 at 14:44
choose the sudo group . – Raja Apr 29 '13 at 14:46
I've tried the following command sudo chown user:sudo /tmp and i received a message regarding the ownership change. However, the issue is still there when I run the guest additions command. Also when I do ls -l I still see root next to tmp (this might be expected) – SomeLinuxNoob Apr 29 '13 at 14:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.