Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to run an application on ubuntu 11.10 64bits. When I do ldd it tells me that

/lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found

I know what causes this problem and reading the solutions on Internet everyone suggesting to upgrade to 12.04 (or 13.04 now!). The problem is that this is shared computer and has several users and in practice I can not upgrade to 12.04. My question is, if there is a way to upgrade only this library? Can I simply copy the so file from my own 12.04 here? If yes, which files should I copy?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

You will need to upgrade very soon if you want to continue to have support. Ubuntu 11.10 will be End of Life on May 9th. As you say it is a shared computer with several users, it would probably be best to stick to LTS releases, as starting with Ubuntu 12.04, they are supported for 5 years across the board.

As for simply installing a newer glibc, it is not so simple. Simply forcing the newr version from a newer Ubuntu release to be installed could result in a completely unusable system. The newer release has a newer tool chain, which the library was compiled against, which may have different optimizations than the older versions, and could result in possible crashes or other errors, even if the system were to appear usable, due to differences in the tool chain. So you should not simply install the new version.

Your best option here would be to upgrade to 12.04, and stick to LTS releases on that system.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.