Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My CPU is i7 dual core. I am running Ubuntu on VirtualBox. İt is extremely slow than other Linux versions such as Edubuntu 13.04 and its previous versions before 12.10. The 12.10 was also very slow.

share|improve this question
    
How much RAM do you have in your VM? Ubuntu is very RAM dependent.. –  Alvar Apr 29 '13 at 13:19
4  
Also make sure you have Virtualbox Additions installed inside your virtual machine. –  TheNumb Apr 29 '13 at 13:22
    
@Alvar see here for some amazing results plus.google.com/u/0/117757136719164314159/posts/MsdGGF3bHEr this was an update I did from 12.10 to 13.04. Will be doing the same for 64 bit soon. So Unity is getting to a ridiculous point of using less memory. Specially with the updates that Unity 7.0.1 carries (Not yet applied to 13.04). –  Luis Alvarado Apr 29 '13 at 13:24
    
@LuisAlvarado Not just Unity Ubuntu in general usess a lot of RAM. if all versions of 12.04 12.10 and 13.04 are slow then it's not RAM so I was probably wrong... –  Alvar Apr 29 '13 at 13:35
    
@LuisAlvarado You have way too little RAM in my opinion, and why aren't you running 64-bit on that CPU? –  Alvar Jun 22 '13 at 12:57

3 Answers 3

It's because if Ubuntu can't use graphics card for acceleration (probably that's what happens in Virtualbox), it uses CPU for rendering graphics trough LLVMpipe. It makes it appear really slow.

In Ubuntu 12.04 and earlier Unity2D was used if hardware graphics acceleration couldn't be used, but in 12.10 and 13.04 Unity2D is dropped in favor of LLVMpipe.

Some desktop environments that don't need compositing (like XFCE) are still fast even without graphics acceleration. That's why few Ubuntu derivatives, like Edubuntu, Xubuntu, Lubuntu, etc. are still fast in Virtualbox.

But if you install Virtualbox Additions, 3D acceleration will be available to Ubuntu inside a virtual machine and it will run at normal speed.

share|improve this answer

After installing VirtualBox Guest Additions execute the following in Terminal:

sudo bash -c 'echo vboxvideo >> /etc/modules'

Then reboot your machine.

share|improve this answer
    
FWIW: I tried this and it had no effect on the graphics speed. (Ubuntu in VirtualBox 4.3.8). The extra CPU core suggested by @9ler helped a little bit, however...enough to be sort of tolerable? –  HostileFork Feb 26 at 17:35

The extra CPU core fixed it for me.

If you have the right video driver then try going from 1 to 2 cores

HowTO:

  1. Shutdown the VM
  2. Go to Virtualbox
  3. Mark the VM
  4. Go to Settings>System>Processor move the slider to 2 cores
  5. Click OK
  6. Start the VM :)
share|improve this answer
    
Thanks - this simple solution worked for me too. –  lakshmipathi Aug 12 '13 at 8:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.