Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The latest version of Gnome-shell starts to display (the top bar appears briefly) but I then get logged out. This happens when I start it with "gnome-shell --replace". Any idea how to make it behave properly? Laptop is a MSI U21, an0d I run with a 'nomodeset' startup option. Without this option the screen clears to just wallpaper and stays that way.

Gnome-shell v2.31.5 Kernel 2.6.35-27 (& 28 as well)

share|improve this question

2 Answers 2

You could try starting it in its own session instead of replacing your current WM with it. There's a package in the repos for that in Maverick--gnome3-session--but if you want it to start a compiled-from-git version instead you'll have to edit the session file (/usr/share/xsessions/gnome3 maybe) or create a symlink to the version you want to start (sudo rm /usr/bin/gnome-shell should remove the old version of the shell from the repos, and then sudo ln -s ~/path/to/your/gnome-shell /usr/bin/gnome-shell should link to it).

share|improve this answer
    
I get the same behaviour when starting it as its own shell (started from the repos, not built by hand). –  Nerdfest Mar 19 '11 at 16:03
up vote 0 down vote accepted

Removing the boot-up option "nomodeset" seems to correct this problem. The MSI U210 needs "nomodeset" to handle an external monitor correctly, and so I have its set as a default. When I booth without it, gnome-shell behaves normally. It sounds like there is a fix for the U21p nomodeset requirement in Natty, so hopefully I'll be able to work as I wish then.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.