Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am try to install xserver-xorg-lts-quantal in ubuntu 12.04 . But it says installing xserver-xorg-lts-quantal will remove many packages. How to keep those packages? Thanks

When I choose xserver-xorg-lts-quantal in synaptic, it gives : enter image description here

When I run in terminal , it gives :

$ sudo apt-get install xserver-xorg-lts-quantal
[sudo] password for xxxxxx: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgl1-mesa-glx : Depends: libglapi-mesa (= 9.0.1-0ubuntu1~precise)
                   Recommends: libgl1-mesa-dri (>= 7.2)
 xserver-xorg-lts-quantal : Recommends: libgl1-mesa-dri-lts-quantal but it is not going to be installed
                            Recommends: libgl1-mesa-glx-lts-quantal but it is not going to be installed
                            Recommends: xserver-xorg-video-all-lts-quantal but it is not going to be installed
                            Conflicts: libgl1-mesa-glx (>= 0~)
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
share|improve this question
1  
If you can list the packages it wants to remove in your question that would help (just in case). –  Jorge Castro Apr 29 '13 at 13:07
add comment

2 Answers

up vote 1 down vote accepted

You don't need to keep these packages if those are replaced by the corresponding quantal packages. If there are other packgages listed that will be removed, you should check the package description of the package in question, but usually there shouldn't be any packages. If there are a lot of other packages listed that will be removed you shouldn't attempt installing the quantal xorg-server stack, especially if everything is working for you at the moment.

share|improve this answer
add comment

The problem is many software packages have a dependency to lbgl1-mesa-glx which is not compatible with xserver-xorg-lts-quantal. See those listed by waterloo2005: 0ad (game), blender... Those are apps requiring OpenGL.

I am a member of the freecad-maintainers team on Launchpad and our precise FreeCAD packages are not compatible with the lts-quantal packages because of that. When one wants to install it on a fresh Ubuntu 12.04.2 install, the package manager wants to remove the whole lts-quantal stack!

(...)

Edit: Upon some research I think this is caused by a build dependency error made by the package maintainers. Our freecad package has a build-dep on libgl1-mesa-dev which maybe should be changed to libglew-dev. I will test this tomorrow. If I'm right this should be reported as a bug to each package that "wants to be removed"...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.