Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Kubuntu 12.04 few days ago on my new ASUS laptop. Right after the installation wired connection was not detected, but wireless worked just fine. So, I was able to get the latest updates, and after that both wired and wireless worked ok.

Yesterday I just wanted to see what happens if I boot in a previous version of Linux (I have that option at boot), and it booted, but network wasn't worked at all, neither wireless nor wired.

The problem is now network isn't working even if I boot normally, the lastest version. I'm a newbie in Linux / Ubuntu, so I don't know what specific information should I provide more and how I find it, but I'll try to do it if someone guide me.

share|improve this question

I had the same issue i have Toshiba satellite c850 -a989, this page really help me

Wireless Lan driver for Toshiba Satellite C850-A823 PSKCCV-02300XAR

but what you should do is :

  1. lspci -l (command to list all devices on your pc).
  2. see what is the type of your both wireless ans LAN driver type. go and download your correspond driver (in my case realtek) and follow the rest of commands

make sure you have packages mentioned in link i gave you. and follow the instruction for set it up

i wish this help you

share|improve this answer
Thank you for your answer. When i typed lspci -l i got an error: asusk@asusk-X75VD:~$ lspci -l lspci: invalid option -- 'l' Usage: lspci [<switches>] then i tiped lspci without parameters, and i got this: asusk@asusk-X75VD:~$ lspci ... 03:00.0 Network controller: Atheros Communications Inc. AR9485 Wireless Network Adapter (rev 01) 04:00.0 Ethernet controller: Atheros Communications Inc. AR8161 Gigabit Ethernet (rev 10) – Luc Apr 29 '13 at 12:56
As for the second part - downloading and installing drivers, i dont really think i have to do that, as it used to work just fine before yesterday. is it possible that simple booting in previous version of linux did delete those drivers? my feeling is they should be steel there, but somehow get deactivated, and i don't know how to reactivate them. i really prefer to try something easier (if there is any) befor going to remove/install drivers, because, as i said, i'm a newbie at linux. – Luc Apr 29 '13 at 12:59
thank you Jai even me i will use your answer, i have also a problem in toshiba c-850 i will also try to reinstall this packages – Manee Osman May 1 '13 at 7:48

All you need to do is reconfigure the Latest Kernel image. Linux kernel work in our PC's to maintain the proper functionality of hardware with OS.

Find out the what is the latest kernel Image.

To do that the best way is installing synaptic package manager.

sudo apt-get install synaptic

then type as synaptic as in unity dash and open it. Then type as linux in the search box and find the latest one and right click it . Then choose reinstall.

look at the image enter image description here

share|improve this answer
Thank you, Jai! after reinstalling the package i was able to check "Enable networking" option (it wasn't there before), then restarted, and now wired connection works well. However, i'm not sure wireless is working; there is no wireless in range, so, i started tethering on my android phone, but i cannot see it on my laptop. – Luc Apr 29 '13 at 14:48
I am up to this only. – Raja Apr 29 '13 at 14:52
well, i'm home now, and i can confirm my wireless is not working :(. any more ideas? – Luc Apr 29 '13 at 17:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.