Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install qt-sdk but get the following error:

The following packages have unmet dependencies:

qt-sdk : Depends: libqt4-opengl-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I was able to find the package in question:

libgl1-mesa-dev : Depends: libgl1-mesa-glx (= 9.1.1-0ubuntu3) but 9.2.0~git20130216.dd599188-0ubuntu0sarvatt~quantal is to be installed

When I open synaptic package manager and try to downgrade the package it tells me that several other packages will be removed. Some of these packages seem important and I am not sure if downgrading is a good idea. I am running Ubuntu 13.04 after upgrading from 12.10. I had the same issue with 12.10 and was hoping that an upgrade would solve it.

So how to fix this ?

share|improve this question

Those packages which caused unmet dependencies problem are installed from a repository that is from other sources. So it isn't cause a problem. So those should be removed.

Try with this :

sudo apt-get remove libgl1-mesa-glx libqt4-opengl-dev && sudo apt-get install qt-sdk

If you want to use that version somehow, you need to find a repository that gives the qt-sdk also. You are lucky if you can find. But rare chance.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.