Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In the Playback tab in pavucontrol I can set the output device to use for each application but not for the "System Sounds".

I have 2 active soundcards, one for my speaker and one for my headphones. If both are enabled system sounds are played in my headphones and if I disable the headphones the sound is played in the speakers.

My "speaker" output device is already set as the default/fallback device.

Is there any way to change so that system sounds always play on the output device connected to my speakers?

share|improve this question
    
I just set up two remap-sinks to split the surround output on my laptop between speakers and headphones. It works great (other than the myriad of volume sliders...which to use?), but now system sounds always play through both the speakers and the headphones. I don't know why pavucontrol won't let the output device for "System Sounds" change. In KMix it shows "Event Sounds", and I can choose to move it between devices, but it doesn't actually move it. I think the module in question is module-position-event-sounds, because it moves the sound depending on cursor position. –  blujay Jul 8 '13 at 6:47
    
"the output device connected to my speakers" -> this is not clear at all... I think you should complete and rewrite a bit your question. –  ttoine Jul 11 '13 at 16:08
    
@ttoine "output device connected to my speakers" is referred earlier as "speaker" output device. The output device which if you set it as the device used for a music player the music will sound from the speakers., sorry but your comment about being unclear is a bit unclear, please elaborate on in what regard that particular part is unclear in relation with the rest. –  phq Jul 11 '13 at 17:59

1 Answer 1

up vote 2 down vote accepted
+25

In Ubuntu, pavucontrol and system settings sound are two GUIs for the same backend config. However, they manage to conflict in many strange ways. You will have to ditch pavucontrol. Just do the same thing in sound settings and it will work - works for me. Set speakers as default, and move players to headphones.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.