Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

Does anyone know how I can get my Canon Pixma MX452 running on Ubuntu 13.04, either via USB or 802.11? I tried to install in 13.04 via USB, but it used a generic text-only driver which didn't work at all. No scanner functionality either.

Thanks in advance!

share|improve this question

marked as duplicate by Takkat, Eric Carvalho, Rinzwind, Fabby, Luis Alvarado Feb 21 '15 at 19:13

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Have a look at this -->… – Meintjes Apr 29 '13 at 7:31
Search the web for "MX450 series IJ Printer Driver Ver. 3.90 for Linux (debian Packagearchive)" – dunaybd May 14 '13 at 15:38
user2088077 - Thanks, that got the printer successfully installed (the driver can be downloaded here: Now all I need is to get the scanner working. – Jesse May 22 '13 at 2:13
I got a *-deb.tar.gz file the above link. How do I install this? I extracted the file and tried to run the, however it just exists without much messages. – Rejeev Divakaran May 27 '13 at 15:40
Rejeev Divakaran - did you try to run it from the terminal? If not, open a terminal, navigate to where the file is, and run "sudo ./install". That should start the installation. – Jesse Aug 3 '13 at 18:12

I have managed to install both the printer and scanner drivers for my Canon MX452, you can grab them from here,

In both cases, you will have to extract the tar balls, and run the script. To run the script you might have to make it executable by running:

$sudo chmod a+x

The printer script will have menus for you to choose between find the printer via USB or Network. I installed mine via network, but in both cases you need to have the printer powered and ready.

I wasn't able to use my scanner using "Simple Scan" but the "scangearmp" application that is installed by the script works just fine. You can start it from terminal by running:

$scangearmp &
share|improve this answer

protected by Community Dec 18 '13 at 22:17

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.