Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The story so far...

Several weeks ago 12.04 crashed while i was on the interweb. Now when i boot, it asks me for a password to log in. I can log in as a guest, but of course all my files and documents are inaccessible to the guest. I have followed the instructions on the wiki.ubuntu.com/RecoveryMode, but at step 7 there is no message saying "Drop to root shell prompt". Instead it reads: "root@clayton-desktop:~# [ 29.606190] tda10048_firmware_upload: Upload failed. (file not found?)" And there is a flashing cursor below.

Any thoughts?

Clayton

P.S. Even though I have been using ubuntu hassle free for many years, I am quite ICT challenged.

share|improve this question

1 Answer 1

Hah, you have a root shell already. Type passwd *insert-your-username-here*, and enter a new password.

share|improve this answer
    
Now have a new password, but can't get past the log in page. I enter the password in the box under my user name and it just brings me back to the same place. Tried it in recovery console, ubuntu, ubuntu 2D, and user defined session. All the same result. –  cjclent Apr 29 '13 at 2:33
    
Did you type exactly passwd clayton? –  Yet Another User Apr 29 '13 at 2:37
    
pretty sure i did because if i type anything else in the space it tells me in red "invalid password, please try again." whereas typing in clayton makes the monitor go blank temporarily and come back to the same login screen. –  cjclent Apr 29 '13 at 3:33
    
Next step: try doing the same procedure, but instead of typing passwd, type adduser test-user --group sudo, and type in a password for it. Now you can login as test-user which is an Admin account. –  Yet Another User Apr 29 '13 at 3:38
    
keeps coming back to root@clayton-desktop:~#and a flashing cursor. The error message is : "adduser: The user 'test-user-group' does not exist. I tried it with 2 dashes between user and group also for the same result. –  cjclent Apr 29 '13 at 4:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.