Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

after upgrade from 12.10 to 13.04 my desktop background turn black after I try to set a image for that. How to fix it? This is my desktop screen. My desktop screen after upgrade to 13.04

share|improve this question
1  
The purge method in the following link helped me. askubuntu.com/questions/204506/… –  Sripad Apr 27 '13 at 3:47
    
Can you right-click on the desktop to change the background to something else? –  Yet Another User Apr 29 '13 at 0:53
    
I already do that but it not work. I find the solution behind and it work> thank for support –  sepdau Apr 29 '13 at 0:56
    
Switching to Adwaita (default) worked. Odd all other GTK themes are broken and cause the odd all white background. –  user153870 Apr 30 '13 at 0:13
    
@Sripad: The purge method relates to Gnome3 and Nautilus. Seems like a Red Herring (false trail) .. –  david6 May 19 '13 at 5:58
show 3 more comments

11 Answers

up vote 43 down vote accepted

I tried this and it worked!

gsettings set org.gnome.settings-daemon.plugins.background active true
share|improve this answer
4  
This is Gnome specific, and may not apply for normal setup. –  david6 May 19 '13 at 6:31
1  
Well this one worked! but after this if set 'desktop icons' to off in Ubuntu tweak, will this error repeat? or now i can freely set them to off? –  Nirmik Jun 6 '13 at 9:25
1  
worked perfect!! –  Silver Moon Oct 17 '13 at 4:29
1  
This fix does not work on Ubuntu 13.10. –  Luís de Sousa Dec 4 '13 at 19:01
1  
Has the same problem here with gnome+ubuntu desktop. This fixed it immediately. Thanks! –  Aras Jan 13 at 3:56
show 3 more comments

Having the same problem.

A workaround I've found through random clicking is to turn on desktop icons.

This can be done with dconf-editor or ubuntu-tweak-tool. The second is the easiest:

sudo apt-get install ubuntu-tweak-tool

Then launch it from the menu.

Under System/Desktop Icons you'll find a toggle to enable icons on the desktop. Switch this on, and suddenly -- wallpaper! This stays there if you turn off desktop icons but disappears again on login.

I've just allowed desktop icons to stay enabled, but simply any from my desktop.

share|improve this answer
    
Thanks! Wallpaper is reborn. :D –  jorgehsrama Apr 22 '13 at 9:07
1  
This works but why? Is it a bug for Unit Tweak Tool? –  Shyam K Apr 28 '13 at 14:02
    
I believe it is a bug in Nautilus (the file manager), but I haven't been able to find a launchpad bug yet. –  senshikaze Apr 29 '13 at 13:17
    
Couldn't find ubuntu-tweak-tool. I found unity-tweak-tool. Is that what you meant? It has the System/Desktop Icons tab, but switching it on (and off) didn't bring the wallpaper back.-( –  Chelmite May 3 '13 at 22:13
1  
using 13.04, only that answer worked for me. this should be the accepted answer. way to go! –  Eliran Malka Jun 15 '13 at 12:02
show 2 more comments

Right click a'nt working for me either...cause the desktop is not handled by file manager now.

Try doing reset of dconf/unity --reset... but u ll lose all your settings....i found one link

https://answers.launchpad.net/ubuntu/+question/217369

may be this can help.


SOME DETAILS: (from link, with minor edit for clarity)

.. you can reset the settings from terminal. (CTRL+ALT+T).

or just Ctrl-Alt-F1

"You will lose all of your settings .. even the background. .. apply the commands below one at time."

Check your spelling, and/or print this first.

gconftool --shutdown

sudo killall -r -I gconf
sudo killall -r -I dconf

rm -rf .compiz* .gconf* .config/dconf/ .config/compiz*

Restart PC

sudo shudown -r now
share|improve this answer
    
Confirm this worked for 13.04; just updated today from 12.04/12.10. –  david6 May 19 '13 at 6:30
    
+1 confirmed working. Thanks –  tilman Jun 11 '13 at 7:01
    
Since none of the other fixes presented here work on 13.10 I decided to give this one a try. It neither brings the background back on 13.10, and now I'll have to go through the pain of reconfiguring. Note that one of the things this fix does is to activate data collection by Canonical and Amazon. –  Luís de Sousa Jan 4 at 16:28
1  
Working, but I had to activate that: gsettings set org.gnome.settings-daemon.plugins.background active true –  euDennis Feb 4 at 0:13
add comment

Quick fix - install "Gnome Tweak Tool" and in the Desktop section uncheck "Have file manager handle the desktop."

share|improve this answer
    
I have already tried disabling the file manager from handling the desktop and once i do that, I have no desktop, the whole setup just glitches out. My whole system constantly freezes until i re enable the file manager handling the desktop. And no rebooting does not help. –  user93768 Apr 26 '13 at 21:04
1  
This is Gnome specific, and may not apply for normal setup. –  david6 May 19 '13 at 6:34
    
This fix does not work on Ubuntu 13.10. –  Luís de Sousa Dec 4 '13 at 19:02
add comment

Right click the desktop and untick "show desktop icons" or "show icons" does that fix the wallpaper display issue? If so, go through Gconf editor to the gnome desktop settings, set draw desktop to off, reboot, set it to on, reboot, and it should work. I had the same issue

share|improve this answer
    
None of those options show up if you right click on the Desktop on Ubuntu 13.10. –  Luís de Sousa Dec 4 '13 at 19:03
add comment

Un-tick "Have file manager handle the desktop" in Gnome Tweak Tool and your wallpaper should show up again.

share|improve this answer
    
This worked for me and was the quickest and simplest solution. –  Phil Hannent May 25 '13 at 6:30
    
This fix does not work on Ubuntu 13.10. –  Luís de Sousa Dec 4 '13 at 19:03
add comment

I got my desktop with these steps

  1. Login to Ubuntu with unity interface
  2. kill gnome-session using terminal (killall -e gnome-session). (Looks like Gnome 3 overrides Unity.)
  3. Step 2 will kill the shell.
  4. login to gnome (u might get a white desktop at this point) and use gnome-tweak tool to turn off "Have file manager handle the desktop". (Tweak Tool > Desktop> Have file manager handle the desktop-OFF).
  5. login back to Unity.

I got my desktop screen back with those steps

share|improve this answer
    
Didnt work for me :( –  user93768 Apr 29 '13 at 21:32
1  
This is Gnome specific, and may not apply for normal setup. –  david6 May 19 '13 at 6:32
    
Does not work on Ubuntu 13.10. –  Luís de Sousa Dec 4 '13 at 19:09
add comment

No need to turn off "Have file manager handle the desktop" or reinstall anything.

Just change theme to default, that will work until this is fixed. Ergo, change GTK theme to Adwaita (using a tool like Gnome Tweak Tool).

share|improve this answer
    
This has no effect on Ubuntu 13.10. –  Luís de Sousa Jan 4 at 16:47
add comment

Same thing happened to me. To resolve I removed the Nautilus (with purge to remove the configuration files), and then installed again. Problems arose broken packages, but it was enough to remove them all and install again also. I ended the session and everything was normal.

share|improve this answer
add comment

You need to purge the PPA from GNOME3. This is probably the issue here an update could cause the problem from this PPA.

I had similar issues for 13.04 and purging this solved it.

Open terminal & follow these steps:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:gnome3-team/gnome3
sudo apt-get update
share|improve this answer
    
yes, this is the solution that worked for me. there is a bug using gnome 3.8 with unity –  dodohjk May 5 '13 at 13:49
1  
This is Gnome specific, and may not apply for normal setup. I don't even have that PPA loaded. –  david6 May 19 '13 at 6:33
    
This fix does not work on Ubuntu 13.10. –  Luís de Sousa Jan 4 at 16:03
add comment

I had this problem when I installed Ubuntu-Gnome 13.10. For me, in order to use a background, I can not use the settings as they just leave me a white screen. Instead, I choose any screen I want to use with Firefox. I right click on the image and choose to use as background. This actually works with the options for stretch, fit, tile, etc.

share|improve this answer
    
This fix does not work on Ubuntu 13.10. –  Luís de Sousa Jan 4 at 16:29
add comment

protected by Community Dec 4 '13 at 20:28

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.