Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Both, Ubuntu 12.10 and 13.04 perform very slow when running in VirtualBox 4.2.12.

How do I run Ubuntu with unity or enabled transparency smoothly with VirtualBox?

share|improve this question

2 Answers 2

Graphic/performance fix for Ubuntu was tested with Ubuntu 13.04, 12.10, and 12.04. Part of this solution applies where aero / transperancy is used including d3d games.

RAM requirements

Recommended graphic memory or virtual ram for aero based operating systems is 256 MB min.ram -768 MB for 13.04

Virtual machine settings

  1. enable 3d support in virtualbox 3d settings

  2. terminal commands:

    /usr/lib/nux/unity_support_test -p 
    

    (Not software rendered:no, unity 3d support:No)

    uname -r
    sudo apt-get install linux-headers-$(uname -r)
    sudo apt-get autoremove
    sudo apt-get install build-essential
    

    now insert vitualbox guest iso from devices and to install manually follow

    cd /media
    ls
    cd username
    ls
    cd VBOX*
    ls
    sudo ./VBoxLinuxAdditions.run
    
    sudo gedit /etc/modules
    

    add "vboxvideo" in the next line after lp means loop>lp>vboxvideo like this click save and file quit

  3. restart the machine

  4. now open the terminal to checkunity 3d is enabled or not

    /usr/lib/nux/unity_support_test -p
    
  5. after this shut down the machine lets increase the virtual ram

  6. close virtual machine and virtual box

  7. follow this path C:\Users\Username\VirtualBox VMs\ubuntu 13.04

  8. now look for ".vbox" extension file and open it with temporarily with wordpad

  9. look for the following lines and replace these in following manner

    Display VRAMSize="128" monitorCount="1" accelerate3D="true" accelerate2DVideo="false"/>
    

    to

    Display VRAMSize="256" monitorCount="1" accelerate3D="true" accelerate2DVideo="false"/>
    
  10. now you can set 256 mb virtual memory for this operating system.

  11. any OS can be provided with desired vram this way

Reference and sources::

babarehner @ e-wrench.com and youtube

sanct on http://ubuntuforums.org/forum.php

rpxmac on forums.virtualbox.org

Related questions on Ask Ubuntu

How do I install Guest Additions in VirtualBox?
How do I enable hardware virtualization technology (VT-x) for use in Virtualbox?
Ubuntu installation in VirtualBox - not using base memory in RAM

share|improve this answer
    
FYI, you can change those VRAM and other settings through the VirtualBox UI now. –  ashes999 Aug 19 at 14:07

Make sure you enable 3D support on Virtualbox, and on guest Ubuntu virtualbox setting. Also give your virualbox enough RAM and cpu cores. Having dedicated VGA will help virtualbox performance as well. How to fix slow performance ubuntu 13.04 running in virtualbox

share|improve this answer

protected by Community Jun 6 '13 at 1:35

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.