Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I no longer need this issue solved as I have replaced Ubuntu with a different OS (nothing wrong with Ubuntu, just fancied a change). I reinstalled Ubuntu into a virtual machine and thunderbird began appearing. I did uninstall Thunderbird and reinstall it, so there maybe a chance that a dependency was not satisfied or whatnot.

I know I keep seeming to have a problem with every distribution, but this time I have no idea... Again, as to why this is occurring!

If I search for Thunderbird in the home and applications sections of the dash I get no results, whether it is installed or not. In fact, it doesn't even appear as a store result! I checked /usr/share/applications and lo and behold... Thunderbird is there! In fact, typing 'thunderbird' in terminal opens it!

Thunderbird KIA

This is also the case with the messaging applet or whatever it is called (envelope in the notification area). It has the permission to appear in that menu according to dconf-editor, alas it decides not to.

Does anyone have any idea what could possibly cause this? I am using Ubuntu 13.04, and I will provide further information if needed. This is not essential but it is one of those small problems that bugs you to find a fix for. I'm not sure what part of the desktop file if any could cause this problem. Any help would be appreciated! And maybe I might stop breaking it soon.

(No idea if this helps or not but I did install Thunar and use that as my default file application thing, although problem occurred before installing that).

EDIT: My thunderbird.desktop file if that helps at all, considering the dash and mmu both use this to discover it. Translations have been trimmed.

[Desktop Entry]
Encoding=UTF-8
Name=Thunderbird Mail
Comment=Send and receive mail with Thunderbird
GenericName=Mail Client
Keywords=Email;E-mail;Newsgroup;Feed;RSS
Exec=thunderbird %u
Terminal=false
X-MultipleArgs=false
Type=Application
Icon=thunderbird
Categories=Application;Network;Email;
MimeType=x-scheme-handler/mailto;application/x-xpinstall;
StartupNotify=true
Actions=Compose;Contacts

[Desktop Action Compose]
Name=Compose New Message
Exec=thunderbird -compose
OnlyShowIn=Messaging Menu;Unity;

[Desktop Action Contacts]
Name=Contacts
Exec=thunderbird -addressbook
OnlyShowIn=Messaging Menu;Unity;

And if any further help, this is what appears when I open Thunderbird via terminal.

(process:2739): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed

** (thunderbird:2739): WARNING **: could not find the desktop file for 'thunderbird.desktop'

(thunderbird:2739): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.36.0/./gobject/gsignal.c:3429: signal name `selection_changed' is invalid for instance `0x7f9818072190' of type `MaiAtkType3
share|improve this question
    
Have you tried to remove and then install thunderbird? like sudo apt-get remove thunderbird && sudo apt-get install thunderbird? –  Alvar Apr 28 '13 at 22:02
    
Do other application appear in the dash? I'm just asking this to make you sure you don't have a different Dash lens selected by mistake, like the music one or the documents one. –  Dan Apr 28 '13 at 22:05
    
Yeah that was my first course of action, I simply got the same problem. Strangely when it was uninstalled it did not appear in the recommended section of the Applications lens of the dash, but in the Ubuntu Store it appeared. Not sure if that makes any difference. And no I tested this with both the home lens and the applications lens, I didn't touch any of the others in the tests. –  A British Person Apr 28 '13 at 22:05
    
Did you try the solutions in this question, this one or even this one? Because I don't believe it's a problem in Thunderbird, but in fact a problem in the Lenses. –  Dan Apr 29 '13 at 7:36
    
Other applications seem to appear fine, it is only Thunderbird that does not appear. I tried those three and none of the solutions worked, permissions are all good and deleting the cache made no difference (albeit slowing it down, presumably rebuilding it). It does make a good point that I should make however is that I did upgrade from 12.10 to 13.04, seeing as that seems to have broken some others I wonder if that makes any difference. –  A British Person Apr 29 '13 at 12:11

1 Answer 1

did you try typing it lowercase in the dash? sudo dpkg-reconfigure thunderbird should fix it there is a issues with thunderbird.

share|improve this answer
    
I'm pretty sure dash is case-insensitive, tried it anyway and it still didn't appear. I also tried the command you gave me and nothing has changed. –  A British Person Apr 28 '13 at 21:54
    
try running sudo apt-get --reinstall install thunderbird –  GM-Script-Writer-62850 Apr 28 '13 at 22:00
    
Unfortunately still nothing, it still does not appear in either of them. –  A British Person Apr 28 '13 at 22:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.