Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just downloaded Electricsheep four days before I updated my Ubuntu software and I fell in love with it.

After I upgraded to 13.04, I'm kind of upset in saying that Electricsheep no longer works. I have no idea how to fix it and I feel helpless with Linux.

As I said, it was working completely fine in 12.10, but now with the Raring Ringtail update:

  • I use Xscreensaver to launch Electricsheep.
  • When I open Xscreensaver, "Electricsheep" is one of the options to choose.
  • When I "preview" ES or even launch the "xscreensaver-demo" in the terminal, it doesn't work anymore; I get an error message.

The error message says:

"detected another electric sheep process. rendering of sheep is disabled using read only access."

Damnit, can someone please help me? I want my trippy screensaver back, it shouldn't be this hard!

EDIT: I contacted the creator of Electricsheep (Scott Draves) via the link to his email address on his personal website and asked for his assistance. Hopefully the Askubuntu community will be able to fix this problem, I'm sure I am not the only one who is having this problem as I have searched and searched.

share|improve this question
1  
Similar or the same as this? askubuntu.com/questions/61305/… –  fossfreedom Apr 28 '13 at 21:02
    
This is mostly guesswork, but maybe ElectricSheep does not need Xscreensaver to start anymore? The error message tells you about another instance of ElectricSheep running. So maybe ES starts on its own, and then Xscreensaver tries to start it a second time, and those two collide? –  Henning Kockerbeck Apr 29 '13 at 10:10

4 Answers 4

Here's what I did:

  1. Get rid of xscreensaver: apt-get purge xscreensaver
  2. Get rid of old electricsheep: apt-get purge electricsheep
  3. Reinstall by following these directions precisely: http://electricsheep.org/node/51

Warning: This install process is why the software center was invented! ;-) It works but it takes quite a few steps. No need for xscreensaver, unless you want to use other modules. Electricsheep installs as a default screen saver with this installation method.

Good luck!

share|improve this answer

No, your not the only one having this problem. I upgraded to 13.04 this morning and the same thing happened on my machine but I did notice something interesting as I watched the install. The Ringtail upgrade appears to come with its own XScreenSaver, so you have two instances of it running now.

However, removing both instances of XScreenSaver, then reinstalling only one, does not fix the problem, it introduces a second problem...Electricsheep will run, but it will not generate the fractal patterns, as it seems to lose its connection to the server these patterns are pulled from.

I am tinkering with Electricsheep now and will update this post if I find anything interesting.

share|improve this answer

I was also unable to get electricsheep to work on 13.04 and 13.10. I tried building the latest version from source using instructions at http://electricsheep.org/node/51 but this also failed to build due to some wxWidget problems.

However, I found a solution which works, but isn't ideal: the windows version works fine under wine. Probably no good for setting it as your screensaver, but if you want to start it manually e.g. along with music in the background, it works fine for me.

share|improve this answer

What fixed it for me was making sure the graphics card was specified in electricsheep-preferences. For instance, I have an AMD Radeon card which uses openGL. Typing "gl" into the video driver field and restarting Xscreensaver fixed the problem. So, in a terminal run:

electricsheep-preferences

In the GUI you should see a field "video driver". Depending on your type of driver the options are ""gl", "x11" and "xv", or leave it blank for the default."

I hope this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.