Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu can't read drivers such as external keyboard, monitor and mouse.

After I forced shutdown Ubuntu, because of the add-on(from FF) I have to shut it down it hanged my PC. Also the Wireless connection is gone.

No external monitor, they can't detect keyboard but, the laptop's keyboard is detected also the mouse.

Currently I have to use Windows to ask question because I can't use Ubuntu I need external monitor to use it.

===== UPDATE ======

I chose the "Advance option for Ubuntu" then I chose the third one and everything went fine. The keyboard the monitor the mouse is now working.

Ok so I tried the other Ubuntu with Linux-Version-Generic-Something? what is this by the way?

I think the problem was the other one, the first one. Still want to know how to fix.

Wahaha I got rid off of Windows again. Yahoo. Please Save Me I Don't Like using W - - - - - S. XD

Oh! and I downloaded 13.04 just in case WE can't fix this thing and reinstall Ubuntu using 13.04. I already downloaded 13.04 ISO file and Back-ed Up my Home folder.

One more thing, the problem now is How can I make that advance-option-choice as my default, not until I install 13.04? or It will be fixed if I will upgrade in 13.04 soon?

Thank You.

==d(O,O)b d(O,O)b d(O,O)b d(O,O)b d(O,O)b d(O,O)b d(O,O)b d(O,O)b d(O,O)b d(O,O)b==

[ Ok so I was looking for some way to know what really happened but, I'm not sure if this Xorg.0.log (in System Log) is the right place to look and I found out that they disabled the "kbd"? "mouse"? "vmmouse"? ]

[ 42.362] X.Org X Server 1.13.0 Release Date: 2012-09-05
[ 42.362] X Protocol Version 11, Revision 0
[ 42.362] Build Operating System: Linux 3.2.0-37-generic i686 Ubuntu
[ 42.362] Current Operating System: Linux ubuntu 3.5.0-23-generic #35-Ubuntu SMP Thu Jan 24 13:05:29 UTC 2013 i686
[ 42.362] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.5.0-23-generic root=UUID=6C2EB8992EB85E30 loop=/ubuntu/disks/root.disk ro drm.debug=0xe plymouth:debug
[ 42.363] Build Date: 11 April 2013 12:55:37PM
[ 42.363] xorg-server 2:1.13.0-0ubuntu6.2 (For technical support please see http://www.ubuntu.com/support)
[ 42.363] Current version of pixman: 0.26.0
[ 42.363] Before reporting problems, check http://wiki.x.org to make sure that you have the latest version.
[ 42.363] Markers: (--) probed, (**) from config file, (==) default setting, (++) from command line, (!!) notice, (II) informational, (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 42.363] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Apr 30 10:45:42 2013
[ 42.363] (==) Using config file: "/etc/X11/xorg.conf"
[ 42.363] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 42.364] (==) ServerLayout "Layout0"
[ 42.364] (**) |-->Screen "Screen0" (0)
[ 42.364] (**) | |-->Monitor "Monitor0"
[ 42.364] (**) | |-->Device "Device0"
[ 42.364] (**) |-->Input Device "Keyboard0"
[ 42.364] (**) |-->Input Device "Mouse0"
[ 42.364] (==) Automatically adding devices
[ 42.364] (==) Automatically enabling devices
[ 42.364] (==) Automatically adding GPU devices
[ 42.368] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 42.368] Entry deleted from font path.
[ 42.368] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[ 42.368] Entry deleted from font path.
[ 42.368] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[ 42.368] Entry deleted from font path.
[ 42.368] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[ 42.368] Entry deleted from font path.
[ 42.368] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[ 42.368] Entry deleted from font path.
[ 42.368] (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
[ 42.368] Entry deleted from font path.
[ 42.368] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/Type1,
built-ins
[ 42.368] (==) ModulePath set to "/usr/lib/i386-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[ 42.368] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 42.368] (WW) Disabling Keyboard0
[ 42.368] (WW) Disabling Mouse0
[ 42.368] (II) Loader magic: 0xb773f640
[ 42.368] (II) Module ABI versions:
[ 42.368] X.Org ANSI C Emulation: 0.4
[ 42.368] X.Org Video Driver: 13.0
[ 42.368] X.Org XInput driver : 18.0
[ 42.368] X.Org Server Extension : 7.0
[ 42.368] (II) config/udev: Adding drm device (/dev/dri/card0)
[ 42.371] (--) PCI:*(0:0:2:0) 8086:27a2:17aa:3801 rev 3, Mem @ 0xd4200000/524288, 0xc0000000/268435456, 0xd4300000/262144, I/O @ 0x00001800/8
[ 42.371] (--) PCI: (0:0:2:1) 8086:27a6:17aa:3801 rev 3, Mem @ 0xd4280000/524288
[ 42.371] (II) Open ACPI successful (/var/run/acpid.socket)

share|improve this question
    
:) I wanted to say: Were you upgrading your system or something like that (when you forced the shutdown)? –  don.joey Apr 29 '13 at 6:10
    
@private No I finished updating with a size of 200MB+. I'm using firefox' add-on. –  gabiro Apr 30 '13 at 14:43
    
Well EVERYONE Thank You for answering but, after updating again its now fixed. All I need now is 13.04 upgrade –  gabiro May 2 '13 at 12:29
    
I had a similar problem I created a bootable 13.04 usb stick using unetbootin and after a successful install. I then rebooted and I had no keyboard no mouse on start-up, or my system would not boot at all and it would get stuck on booting the usb drivers. I re-made a new bootable usb directly in ubuntu following these instructions and reinstalled and everything worked. ubuntu.com/download/desktop/create-a-usb-stick-on-ubuntu Old versions of unetbootin may not be copying files over again –  Rick T Jun 12 '13 at 14:50
add comment

1 Answer 1

I aslo had this kind of problem when I updated from 12.10 to 13.04. And the same with a clean install on one of my desktop pc's.

Here's how I solved the issue, I don't know if it also will resolve the wifi issue that you have.

When you boot up and you see the screen where Ubuntu Unity hangs hit Ctrl + Alt + F1 to go into the terminal mode. Enter your username and password.

First of all update: sudo apt-get update and also upgrade afterwards. Install Unity-2d and if you have a Nvidia graphics card install nvidia-current. Then reboot init 6.

Once Unity is loaded your mouse and keyboard should work now.

Best regards,

Kiwaf

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.