Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So basically before Ubuntu 13.04 I was running 12.10. I had Windows Boot Loader the default. If I chose to boot to Ubuntu, it would go into grub, but grub was set to 0 seconds so it would basically skip grub and just go straight into ubuntu.

Now, after upgrading, Grub is back. I used EasyBCD to get everything correct on the Windows side but now I cannot figure out for my life how to get grub to appear AFTER Windows Boot Loader.

I tried to go into the grub config and change the default to 4, which is the line where Windows is on. All that did was highlight Windows on start instead of going straight into the Windows Boot Loader first.

I also tried to use Boot Repair to change "OS to boot to by default" to Windows, which also did not work.

Can someone please help me get it back to how it was? I've been trying for hours.

share|improve this question
    
This doesn't make sense. You said you boot using easyBCD and hid the grub menu. But now you are setting the grub default to Windows. So what is in control (what bootloader is in the drive MBR)? Please add a pastebin link to the bootinfoscript. Thanks (PS sometimes grub overwrites the windows boot sector which will load grub whenever you try to boot windows - this could be happening, but the bootinfoscript will show that if so) –  bcbc Apr 28 '13 at 18:25
    
Okay. Here's the boot info. pastebin.com/NiftuuUv –  Jack Apr 28 '13 at 18:47
    
The bootsector is ok. What happens when you hold down the Shift key at boot? If you want to switch back to easyBCD you should just have to reinstall the windows bootloader, or do you want it to be the default in grub only? –  bcbc Apr 28 '13 at 19:17
    
Similar or same as this? askubuntu.com/questions/62440/… –  fossfreedom May 7 '13 at 9:24
    
@fossfreedom I say the same. –  Braiam Dec 25 '13 at 18:07
add comment

3 Answers

I've been through it. Here's the way I solved it. You need to restore MBR, so it boots into Windows again, not Linux, THEN add Linux. 1. Boot from Windows installation disk; 2. Choose Repair/Startup repair; Windows will restore MBR; 3. When done, reboot into Windows; 4. Open EasyBCD, and add Linux; 5. On reboot, you will see the good old black screen with Windows bootloader and two entries: Windows and Linux; 6. Voila.

share|improve this answer
add comment

I've found this very usefull but found an easier way to fix this. When you have access to your windows installation and have EasyBCD installed. You can just repair you MBR from within the tool.(done with EasyBCD 2.2.0.182)

  1. Open EasyBCD and click on "BCD Deployement"

  2. In the section "MBR Configuration Options" ensure that "Install the Windows Vista/7 bootloader to the MBR" is selected and click the "Write MBR" button

  3. Reboot and enjoy the magic of Windows Bootloader

Hope this helps someone

share|improve this answer
add comment

Go to shell in boot loader menu and type:

chroot / 
mount /dev/sda /grub/boot
mount /dev/sda2 /win
install grub boot loader again on grub2
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.