Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just installed 13.04 with built-in Firefox 20.0. Strangely enough in Yahoo Mail I cannot view contents of any mail folder except Inbox. Any other folder (Sent, Trash, etc) when clicked won't open but for a fraction of a second, then disappear, and contents of Inbox are shown again. And it keeps checking for new mail every 5 seconds!

3.8.0-19-generic #29-Ubuntu SMP Wed Apr 17 18:16:28 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

share|improve this question
    
What is your internet speed connection? Anyway, I can imagine that this problem is not caused by Ubuntu, so this post could be off-topic –  Lucio Apr 28 '13 at 18:00
1  
Have dual boot on same machine with 13.04, and in Windows 7 (IE, Chrome) Yahoo Mail behaves normally. Just checked my my internet connection and it looks fairly good: Download speed: 20196 kbps (2524.5 KB/sec transfer rate) Upload speed: 19108 kbps (2388.5 KB/sec transfer rate) Ping: 5 ms Sun 28 Apr 2013 09:11:09 PM EEST –  ego Apr 28 '13 at 18:13
    
Have you tried using another browser inside Ubuntu? So you can confirm if this is a caused by Firefox or by Ubuntu. –  Lucio Apr 28 '13 at 18:17
    
I used to have Chrome for Ubuntu installed in 12.10 but when I upgraded online to 13.04 the other day, it vanished, so I only have FF at the moment (which I have become a fan of) and do not plan installing other browser. –  ego Apr 28 '13 at 18:24
    
I didn't see the problem in google-chrome-stable - but I checked it after I removed the unity-webapps-yahoomail, but before I restarted Firefox (so the problem was still happening in Firefox). –  Eponymous May 1 '13 at 13:52
add comment

3 Answers 3

I have same problem. Linux mint 14 Nadia, is just fine with yahoo mail, only in ubuntu 13.04. It is only yahoo for me, as gmail is fine. Fond a solution here: http://ubuntuforums.org/showthread.php?t=2139807&p=12623430. I opened synaptics and marked for full removal, but synaptics crashed. So I opened up in terminal and typed:

sudo apt-get remove unity-webapps-yahoomail

And everything works again! I do not know what the webaps does for me, I read that I could reinstall it and it would work, but for now, I will leave it uninstalled and enjoy my yahoo. mail! Thank you Jenks 141 for leading me to the solution!

share|improve this answer
1  
Indeed, removing unity-webapps-yahoomail (via command line or via Ubuntu Software Center) restored normal functioning of my Yahoo Mail. I think it's a bug that makes Yahoo Mail (accessed in Firefox) to continuously and endlessly check for new mail which is preventing access to any mail folder (except Inbox) and indeed opening any mail message whatsoever. –  ego Apr 29 '13 at 17:29
add comment

I had the same problem after installing the latest version of Ubuntu (13.04)

With the help of a friend who is rather more experienced in the world of Linux, I found a solution.

Go to the Tools option on the menu bar, click on Add-ons, choose Extensions, and disable Unity Desktop Integrations 2.4.6

share|improve this answer
add comment

I have used the fix 'sudo apt-get remove unity-webapps-yahoomail' to address the problem with Yahoo mail in Firefox on newly installed Ubuntu 13.04 and it will postpone the problem for a few seconds, then starts continually checking for new emails again and blocking access to any mail folders by instantly closing them if opened....so not the fix needed.

Update to now successful fix: First close Firefox, then enter the above fix into 'Terminal' followed by a reboot. Upon opening yahoomail for the first time following reboot, do not install for added features, instead choose 'don't ask again' and the problem is solved.

share|improve this answer
add comment

protected by Community May 25 '13 at 8:53

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.