Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I received a message this morning announcing that the new Ubuntu Raring Ringtail 13.04 is now available. I had to use the computer for something pretty urgent so I told Ubuntu to ask me to upgrade later.

After my business was over, I tried to find a way to bring back that upgrade window. I tried restarting but it didn't seem to reappear. So I went to my settings, opened up "About This Computer" and clicked on "Install Updates"... but it didn't work. I tried it multiple times but it always shows an error message: "Make sure you are connected to the internet"; but my internet works fine -- I can surf, watch and all that on my computer... but not upgrade, for some reason!

Is it because there is a lot of traffic on the download server or something? I would love to upgrade as soon as possible!

Thanks in advance for your timely response!

share|improve this question
    
Do you have 'upgrading to the newest verion' on just for lts versions(if you do change to upgrade to the latest versions) or the update manager doens't work at all? –  Pedro Diniz Apr 28 '13 at 15:29
add comment

marked as duplicate by Jorge Castro, Mitch, jrg Apr 29 '13 at 1:13

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

up vote 1 down vote accepted

run sudo do-release-upgrade another way that is not usually recommended is this:

`sudo sed -i "s/$(lsb_release -sc)/raring/" /etc/apt/sources.list{"",".d/*"};sudo apt-get update;sudo apt-get dist-upgrade`

the second one will also update any ppa you have, but if they don't have a raring version yet they will 404 error on you (eg getdeb) If you have a nvidia gpu is highly recommend using this before rebooting:
https://github.com/GM-Script-Writer-62850/Ubuntu-Mainline-Kernel-Updater

share|improve this answer
    
Thanks for the code, 13.04 is now being downloaded with 14 minutes left to go. I have an old Mobile Intel x3100 GPU (which doesn't seem to be recognised -- but that's another issue) so I didn't think I'd need the Mainline Kernel Updater and went straight to the Terminal instead. Thanks so much! –  Robel Bayisa Apr 28 '13 at 15:38
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.