Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use Ubuntu 12.04. Today I tried to burn an ISO file in a DVD-R disk using K3b. It used to work, but today, after one and a half minutes, it stopped saying that "cdrecord has no permission to open the device". I searched for a solution, and I found that I had to do something with k3bsetup. I tried to use it, but I had no idea what to do, and I couldn't find a guide, so I checked cdrecord and clicked apply. Now there is another error; it says "cdrecord returns an unknown error! (code 254)". What should I do?

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

I had similar problem and fixed it with the following steps:

Open k3b. Go to Settings -> Setup system Permissions. Select all options and apply.

It will ask for your password (you must be admin).

If it doesn't works, open k3b from terminal with sudo k3b, and try same steps as before.

Should help.

share|improve this answer
    
I selected all options except the "Use burning group", because when I tried, it said "There isn't group "burning" ". After that, there are some other errors, such as "OPC failed", "probably a buffer underrun occured", and once the "cdrecord returns an unknown error! (code 254)". I also tried reset, but still nothing. –  user64386 Apr 28 '13 at 21:09
    
I tried today again to write a DVD and it worked. Thanks! –  user64386 Apr 29 '13 at 7:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.