Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having a big time getting my laptop to boot again. I have launch the upgrade process yesterday before going to sleep and today upon waking up, I saw that the upgrade somehow failed to complete successfully and some package could not be updated. I was upgrading from Quantal to Raring. The laptop stopped responding and I had to restart it. However, from now on, it will not boot. Upon booting, I am getting the following message:

General error mounting filesystems.
CONTROL D Will terminate the shell and reboot this system

As I am new to linux, I am stuck right here and have no clue what I should be doing. Therefore I searched around the forum here as I always did in the past and I found some suggestions.

Trying to use the LiveCD

One suggestion was to use the liveCD to boot the system and after it boots, there are direction to solve the problem. I tried using the liveCD but strangely, the liveCD will not even load and fails. I get the menu screen to choose 'Start/Install Ubuntu' and when I chose that... It will start loading and will freeze when it is 'mounting filesystem' and after a while will land on the BusyBox console. And from there, I am stuck. No idea how to proceed since the LiveCD will not load.

Using Boot Repair Disk

The other suggestion was to use the Boot Repair Disk and it will correct the errors with the broken packages and grub. I downloaded it and burned it on a CD. I then loaded it on my laptop. I was able to successfully boot the Boot Rapair Disk and I chose the 'Recommended Repair'. The repair tool started and did some stuffs and afterwards a dialog message showed up saying 'Boot successfully repaired' and asked me to reboot the machine. I was quite delighted but upon rebooting, I ended up with the same problem. It looks like nothing was fixed. The Boot Rapair Disk gave me this url where it has saved some report apparently.

Information regarding my disk

I have a single hardisk with 320GB. It has been partitioned in 3 parts. 1st is ext4 where the ubuntu files are stored, 2nd is the swap partition and 3rd is the logical partition where I store my stuffs. I do not have a dual booting system and use only ubuntu.

So, currently I am a bit desperate as I need to get some work done but I am unable to use my machine. However, I do know that there are very helpful souls here and as I have found many solutions to my problems in the past from here, I expect this problem will not be leaving for long now that I have placed it here. If more information is needed, I will gladly add it.

Thanking you in advance...

share|improve this question

Try to run this, assuming it will boot to a console:
sudo apt-get update;sudo apt-get dist-upgrade
You may want to try using gparted to check/repair the file system (right click the partation) from a live session

share|improve this answer
I cannot get into a live ubuntu session. I used the Boot Repair Disk and I did have a live session with it. But when I click on the partition, there is not 'filesystem repair' option. Only mount/unmount volume. Also, gparted is not present in this CD. When running the command above, it seems to be updating the current live system and not the installed one. – Nadeem Muhammad Apr 28 '13 at 14:33
The Boot Repair tool has an advanced option and from there, I can see an option to 'repair filesystems'. But I am pretty scared to try it as I warns me to backup my data etc. I am afraid that it might make things worse. Advice needed. Thanks – Nadeem Muhammad Apr 28 '13 at 14:42
i said in gparted, i am adding a screenshot to my answer, the partition needs to be unmounted for check to work – GM-Script-Writer-62850 Apr 28 '13 at 14:54
How do I run gparted? – Nadeem Muhammad Apr 28 '13 at 14:59
search for it in the dash on a live cd/usb; you can use partedmagic if you prefer not using ubuntu's live session – GM-Script-Writer-62850 Apr 28 '13 at 15:00

You can delete the hard disk content and install ubuntu again.

share|improve this answer
Yes I can do that but what about all the programs which I have installed and customised? Will I have to re-install them one by one? – Nadeem Muhammad Apr 28 '13 at 15:13
Unfortunally, yes, and also your data. – Pedro Diniz Apr 28 '13 at 15:14
The LiveCD is not loading and it is freezing at some point when it comes to 'mounting filesystem' and sending me to the BysyBox console. So how do I re-install ubuntu? Should I format the partition on GParted first? – Nadeem Muhammad Apr 28 '13 at 15:47
If you can mount the partiotion on gparted try to use everything to delete it. Then you delete the other partition. Then the other and finally you connect every partition and re-install ubuntu. Or just simply buy another machine. – Pedro Diniz Apr 30 '13 at 16:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.