Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have gone through other posts to solve the problem, but it seems bit difficult to fix it. I have ubuntu 12.10 on HP notebook. I don't see 'enable wireless' option on the control panel. Could someone guide me through this. Thanks

share|improve this question

1. First thing to check is you didn't disable wireless with your keyboard (more common than you might think). If you have a networking key on your keyboard see if that fixes it.

2. If not, do you see the network monitor applet in the top bar, where the battery icon etc. are? There should be a dropdown menu with an "enable wireless" setting or something similar. Eg in Gnome Shell:

Enable wireless setting in Gnome Shell

3. In the System Settings, you should see "Network" in the "Hardware" section. From there you should be able to select Wireless settings and turn on networking. Again, this is how mine looks in Gnome Shell (yours might be slightly different if you're using Unity):

Enabling wireless in Gnome Shell

4. You can also use the terminal, if you're comfortable with that. First you need the name of your connection, probably 'wlan0' but sometimes 'eth1'. Run ifconfig and you should see a number of entries listed. Then to turn the wireless on, run sudo ifconfig wlan0 up, or sudo ifconfig eth1 up.

5. If none of those work, it may be that you don't have the correct drivers installed. Afaik, HP notebooks are very well supported, so I doubt it is a driver issue. Nevertheless, you can check your wireless card is activated and such using the command sudo lshw -C network as described here. Look for the one with description: Wireless interface and make see if the line configuration: has a driver listed. If you need a driver, check "Additional Drivers" under "Hardware" in System Settings.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.