Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have always had trouble setting up samba shares with ubuntu. In the past I've tried getting it to work by configuring /etc/samba/smb.conf but never achieved what I wanted. Last time I managed to get it working by making a share with nautilus built in file sharing (which utilises samba). Now when I try do it again it doesn't work. (running ubuntu 10.10 Desktop x64)

What I'm trying to achieve is a share which is available for multiple users (those who are in the same group) and not just the owner (who also is included in the group). As it is now I can connect with only the owner, the others are getting an error when I try to connect with windows 7. All the users are within the same group and the folder permissions are 770. The files and folders have the correct group settings.

I think there is no restrictions in the User Settings for the other users blocking them and I marked "make available to other users (or whatever it says)" in the file sharing dialog.

What can I do?

share|improve this question
    
I figured it might got something to do with the way the filesystem is mounted. Currently the options in /etc/fstab is "defaults". But then I read something about that it prevents other users than the owner to mount the filesystem. Would "defaults,user" take care of the problem? –  Niklas Mar 2 '11 at 15:22
    
From reading this, it looks like you resolved the issue? –  bumbling fool Mar 3 '11 at 16:52
    
You would think that but I don't know where the nautilus file sharing configuration is. I can't find the shares in /etc/samba/smb.conf and I need to set those settings on the specific shares. Where does nautilus specify it's shares? –  Niklas Mar 3 '11 at 22:00
    
I finally where able to solve this, read this thread to find out how: ubuntuforums.org/showthread.php?t=1699453&page=2 –  Niklas Mar 6 '11 at 21:00
1  
@Niklas Please post an answer to your own question, explain what you needed to do briefly, and include the link. After two days (I think :), you can mark your own as the accepted answer. Answering your own question is completely welcome! –  Stefano Palazzo Mar 9 '11 at 7:42
show 1 more comment

1 Answer 1

up vote 0 down vote accepted

I finally was able to solve this. Visit this page for a detailed walkthrough:

http://ubuntuforums.org/showthread.php?t=1699453&page=2

It turned out that the problem was because of a flow of permissions. I also had the same problem on another setup I did later on :) It's basically that the user lacks read permissions to the parent folder that holds the share. When setting up shares it's easiest if you set full permissions to everyone, from the directory holding the shares and onwards, and then afterwards start limiting permissions so that you don't bang your head against a silly problem like I've done several times ;)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.