Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I ran into a problem with Ubuntu 13.04.

I installed it without any problems. When I reboot my machine it hangs on a black screen with a blinking cursor after grub.

  1. I tried recovery mode as well and it hangs at switching to clock source tsc.
  2. I tried the nomodeset parameter for the kernel, but it results in the same.

I used a dualboot Ubuntu 12.04 & Windows 7 before, now I only want Ubuntu 13.04 alone.

Can someone help me with that?

share|improve this question

1 Answer 1

Try booting from Ubuntu install CD:

sudo mount /dev/sda1 /mnt
sudo grub-install --root-directory=/mnt /dev/sda

if it doesn't work, try chrooting:

sudo mount --bind /dev /mnt/dev
sudo mount --bind /proc /mnt/proc
sudo chroot /mnt
sudo grub-install /dev/sda1

Debugging grub loading:

Hold shift during boot, then hit e to edit the GRUB entry. Remove the part that says "quiet splash" and replace it with "text" to see what's happening during boot.

Have a look here: http://superuser.com/questions/378947/linux-kernel-hangs-at-switching-to-clocksource-tsc-on-pentium-4

and try to edit the boot entry (just add clocksource either with hpet or acpi_pm value):

clocksource=hpet quiet splash

If it works you might want to change in /etc/default/grub this line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash clocksource=hpet"

then run

sudo update-grub
share|improve this answer
    
When I try to run grub-install /dev/sda it say : Path `/boot/grub' is not readable by GRUB on boot. Installation is impossible. Aborting. –  wurstchenman Apr 28 '13 at 11:53
    
do you have just one partition? paste here output of fdisk -l or rather df -m –  Tombart Apr 28 '13 at 11:58
    
Yes I only have one partition for the system, and a second one for swap. Device Boot Start End Blocks Id System /dev/sda1 * 2048 242069503 121033728 83 Linux /dev/sda2 242069504 250068991 3999744 82 Linux swap / Solaris –  wurstchenman Apr 28 '13 at 12:58
    
I've updated the answer –  Tombart Apr 28 '13 at 13:44
    
I will try that, but just to be clear, the problem is right after grub. I keep you updated –  wurstchenman Apr 28 '13 at 14:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.