Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried installing nvidia drivers in 12.10 via x-swat repository, and primus, and noveau, and a million things i found on the net and everything just broke the system, until I finally got bumblebee to run and it was okay for some days...

But the next upgrade again broke the X and I had to do low-level stuff. Fortunately, 13.04 was released and I did a clean install.

Now in 13.04, I need someway stable enough to get my GPU benefits without spending all nighters everytime I update my system.

In that line, I downloaded the nvidia linux drivers from nvidia site (310.44 version) shown for my GEFORCE GT635M graphic card. (BTW is this the latest version? I saw 310.88 somwhere on internet) But now am stuck with the below questions:

1) How to install this .run file in ubuntu 13.04 without breaking anything now, or in the future updates.

2) Is installation of proprietary drivers stable enough?

3) Am sort of mixed up about the various terms i have read about - primus, nouveau, bumblebee, optirun, etc... Can anyone help me with some accurate and decent reading material/sites where I can read and understand what is what?

4) and finaly is there a GUI i can use for config and stuff post installation.

5) Also, why I am not getting the available drivers listed in the additional drivers section of the settings GUI? For me that proprietary drivers page is all greyed (disabled). There are no device driver options listed. Is there a way to get my nVidia drivers shown here?

As suggested by Tuxest, the below commands give the provided output:

~$ sudo lshw -c video

*-display
description: VGA compatible controller
product: 3rd Gen Core processor Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 09
width: 64 bits
clock: 33MHz
capabilities: msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:46 memory:f7400000-f77fffff memory:d0000000-dfffffff ioport:f000(size=64)

~$ lspci -nnk | grep -iA3 vga

00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
Subsystem: ASUSTeK Computer Inc. Device [1043:1447]
Kernel driver in use: i915
00:14.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller [8086:1e31] (rev 04)
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108M [GeForce GT 635M] [10de:0de3] (rev ff)
03:00.0 Network controller [0280]: Atheros Communications Inc. AR9485 Wireless Network Adapter [168c:0032] (rev 01)
Subsystem: AzureWave Device [1a3b:2c97]
Kernel driver in use: ath9k

Does is all look okay? Why is the nvidia not displayed in the first command output?


Update: I installed the 319 drivers along with bumblebee and the system is running just fine... But have a follow up question here:
No nVidia/nouveau modules loaded, but sytem working fine?

I need to update the system kernel and am afraid to proceed... Can someone please help?

share|improve this question
    
What do you mean by "not getting the available drivers listed in the additional drivers section of the settings GUI"? You mean like this: psychocats.net/ubuntucat/wp-content/uploads/… –  Tanel Mae Apr 30 '13 at 10:27
    
Yes Tuxest! For me that proprietary drivers page is all greyed (disabled). There are no device driver options listed. Is there a way to get my nVidia drivers shown here? –  charlie Apr 30 '13 at 11:15
    
I've had great luck just installing the drivers through synaptic. Have you tried that yet? When installing from there, yes there is a GUI for config. –  meteorainer Apr 30 '13 at 12:28
    
@meteorainer - your response should have been an answer, not a comment. Anyways, is synaptic installation any different from sudo apt-get ? If yes, then I can try that out, but would need more details. Also, what kind of GUI are you talking about here? –  charlie Apr 30 '13 at 13:03
    
Confirm that you have "Proprietary drivers for devices (restricted)" checked under System settings-> Software & updates. If it is checked and driver does not come up under Additional Drivers then for some reason your GPU doesn't get properly detected. If that is the case please give more details on your laptop model and Ubuntu install (is it 32 or 64 bit?). –  Tanel Mae May 1 '13 at 6:42

2 Answers 2

up vote 1 down vote accepted

I have no experience with these drivers and I don't own such hardware but I will try to give some preliminary information and hopefully it helps a bit.

  1. There is no special way that would provide higher reliability for something that was installed from .run file. If you want stability then always prefer installing software from Ubuntu repositories – not getting bleeding edge also means less bleeding. I have one tip though. With some run files there is an option to create deb-file from the installer. If you install that deb-file it is much easier to remove/replace it later. I have done it previously with ATI drivers but based on this answer it seems to be much more difficult with Nvidia drivers. There is a good guide about installing run files here.

  2. Depends on so many things that it is best to try what works best on your system.

  3. Proprietary drivers are called after nvidia and open source drivers are called nouveau. The rest that you have named are special extras for special hardware. Namely for Nvidia Optimus technology that you have in your laptop. Basically it means you have two graphics adapters – one lighter that is used on regular tasks and other much more powerful that is used when needed. For handling all that complexity extra software is needed and this is exactly what Bumbelbee is for. In theory one could use Bumbelbee both either with proprietary driver or nouveau driver. For Bumbelbee setup on Ubuntu see this. As I read from here you could check /etc/bumblebee/bumblebee.conf file to see which driver Bumblebee is using. Primus and optirun/VirtualGL are pieces of software that help in 3D rendering (process of generating an graphical images) and Bumbelbee uses them to get its job done. Apparently as they claim Primus is newer and better alternative to VirtualGL. To read more about Primus and how to install it see this.

  4. With proprietary driver you get GUI rather similar to Nvidia settings in Windows. With open source drivers you can use GUI settings managers that come with Ubuntu. In my experience both options work fine.

  5. As I understand it from your comments then there is either a bug in your system or in Ubuntu in general or you either have too new hardware (its a sweet machine). The point is that if there are proprietary drivers allowed in your system but Ubuntu doesn't offer driver under Additional drivers then either hardware doesn't get detected or the driver in the repository doesn't support your hardware or something is broken. So it might also be a bug that you should report. In any case, looking at the current situation my advice would be to try set up nouveau with Bumbelbee and preferably start with fresh install as after “trying several things” tends to mess up things. All you need should be in the ppa:bumblebee/stable and Ubuntu repositories. Make sure you follow the Bumblebee guide in Ubuntu wiki. It is always good to try some already tried options again in a clean system when you know better what you are doing and what is what.

Other tips:

  • Use synaptic as advised by meteorainer as it is especially good tool for such troubleshooting situations. It is as surgical as you can get in package management without being command line guru.
  • When you try one driver see before that other driver is removed (in synaptic select to remove completely particular package or on command line use apt-get --purge remove package-name-goes-here). Having open source driver and proprietary driver installed at the same time is very likely to cause problems.
  • Keep track of what driver is being loaded. Especially when things are broken. The most important part of solving complex problems is having the data and in this case it means making good notes. There are various options for doing this. For an example you could use:

~$ sudo lshw -c video

or:

~$ lspci -nnk | grep -iA3 vga

If you still get stuck don't hesitate to expand your original question with new information.

Also if you find this answer useful click upper arrow in the upper left corner.

PS! If there is any incorrect information here let me know and I will edit my text.

share|improve this answer

Per OP comment, creating answer....

I've had great luck just installing the drivers through synaptic. Have you tried that yet? When installing from there, yes there is a GUI for config.

On the technical end I'm not really sure if they are any different. Sorry, I'm still learning Linux.

What I did was load up synaptic and search on nvidia. You will get several options, just select nvidia-<version>-updates-dev and nvidia-settings-<version>-updates for installation. The most current version right now is 313, but I had good luck with 310 as well.

Let those install. Shouldn't take long. While you can technically do a sudo /etc/init.d/lightdm restart (or whatever windows manager you are using) I prefer to just restart. No issues along that road for me.

nvidia-settings gui for reference:

enter image description here

share|improve this answer
    
Thanks a lot for the details. This does seem promising and will try it when I get back from work. But wanted to get the community's opinion on this method (sorry I really dont wanna mess up my installation again) and also, are these driver versions listed the same as what are available from download on the official nVidia linux support website? –  charlie Apr 30 '13 at 14:03
    
No apology necessary. When I did the first driver update from 304 to 310 lightdm didn't want to restart so I had to completely strip out the drivers from terminal then reboot and reinstall from synaptic. There is something about doing it manually that causes a version mismatch between kernel and driver, but 30mins of fiddling got it back up without any serious pain. –  meteorainer Apr 30 '13 at 14:27
    
Sign! All look swell on the forums. I tried 2 things - installing the 310 drivers available in synaptic, and installing the drivers I had downloaded from Nvidia site....both broke my unity and reduced the screen width to half –  charlie May 1 '13 at 5:24
    
Try sudo apt-get remove nvidia* This will remove anything nvidia related. You will be back to stock drivers. Then retry 310 or 313. I assume you have already checked for compatibility with your video card as well. –  meteorainer May 1 '13 at 14:05
    
Yes I checked the compatibility and tried with various driver versions. Still no benefit!..but thanks anyways –  charlie May 2 '13 at 15:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.