Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been installing bumblebee and primus in order to play a few game on my laptop. When I test them with respectively optirun glxspheres primusrun glxspheres, I see an adequate increase of the framerate in optirun but primusrun run gives about the same rate as glxspheres, not better.

It seems like primusrun doesn't use my Nvidia card or uses nouveau? Is there a configuration step for primus I missed? All I did was editing xorg.conf with the correct BusID "PCI:01:00:0", using lspci | grep NVIDIA (see http://ubuntuforums.org/showthread.php?t=2129405).

I am using up-to-date bumblebee, primus, nvidia-current drivers. The card is a nivida GT 620M. I don't know which information I should add but I'm here for more details!

Thanks for reading!

share|improve this question
    
vblank_mode=0 optirun -b primus glxspheres –  Qasim Apr 28 '13 at 6:40
    
This gives the same result as primusrun glxspheres: both are working, but as slow as glxspheres alone. –  ForeverOz Apr 28 '13 at 6:46
    
Run this command > vblank_mode=0 optirun -b primus glxspheres –  Qasim May 18 '13 at 14:47

1 Answer 1

I've had the same problem. "primusrun" says on console, that it's using my Intel card in place of NVidia. "optirun" is ok. Have done some research and it seems normally "primusrun" has limit to 60 fps, because most of LCD displays doesn't show more. But if you add and execute "vblank_mode=0 primusrun " you disable this limit (for example for benchmark purposes).

But... the problem that "primusrun" runs on Intel card remains, so I must execute "vblank_mode=0 optirun -b primus ", and then all is working fine.

For normal use, just execute "optirun -b primus " (without "vblank_mode=0"), because you won't see difference and save some computer resources (and power) :)

Btw. I use newest available on PPA bumblebee/primus version.

share|improve this answer
    
I do not use Ubuntu but this anwser was really valuable for me. Thank you very much ! –  JB Jansen Nov 20 '13 at 22:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.