Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I used a Live DVD to upgrade to 13.04. However, this reset my fstab file, which I had previously set up to auto-mount using pysdm. Because of this, when I reinstalled Steam, it was unable to detect the games I had previously installed to my Windows partition. Attempting to re-add this folder to my Steam Library Folders left me with an error message stating

New Steam library folder must be on a filesystem with executable permissions.

I then edited my fstab file to add the appropriate partition with the options uid=1000,gid=1000,dmask=027,fmask=137, but I still get this error. How do I re-add my old Steam Library Folder?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I also have Steam libraries on an NTFS partition, on Ubuntu 13.04, here is the fstab entry for that partition (I removed the rest):

# <file system>         <mount point>      <type>   <options>       <dump>  <pass>
...
...
...
#add execution right on data partition
UUID=50B06A2EB06A1B2C /media/etienne/data   auto    auto,exec         0       0

You probably need exactly the same options except for the partition's UUID, to get the UUID of your partition, locate your partion in /dev and use blkid, for an example if your partition is /dev/sda1 use: sudo blkid /dev/sda1 You will get a result like this:

etienne@etienne-laptop:~$ sudo blkid /dev/sda7
/dev/sda7: LABEL="data" UUID="50B06A2EB06A1B2C" TYPE="ntfs" 

If it still doesn't work it means you need to add other mount options, in this case have a look at that question.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.