Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a home setup running dual boot Win7 and Ubuntu 12.10. The way I have it set up is using the Windows boot manager to allow choosing OS at boot (Win7 is the first option so the kids can get to it by default), if I choose the ubutu option I get to Grub and boot into Ubuntu. Not sure if it makes any difference but the system has dual HDDs running in RAID-1.

So, Thursday evening I allowed the Software updater to update me to 13.04. The app warned it would take 35 minutes to download and possibly a few hours to install. I watched for a while and the download of 1400 odd packages was progressing well, up to about 800-900. I walked away and came back probably 15 minutes later, my xscreensaver had kicked in but was frozen so I don't know where things got to on the download/upgrade. The mouse pointer would move on the screen, but nothing else responded. I decided to leave the computer to see if maybe it was actually working in the background - I left it for about 4 hours and nothing at all changed so I finally powered down.

When I powered up I can still get into Win7 (good news) and hitting the Ubuntu option in the OS selector takes me to Grub2.00-7Ubuntu11, but selecting Ubuntu on this Grub menu gives first a black screen with a blinking cursor then a message:

General error mounting filesystems.
A maintenance shell will now be started.
CONTROL-D will terminate this shell and reboot the system.
root@kibi-blah-blah:~#

From there I am a bit clueless. I can do

cd ../home/kibi

and I see all my stuff is still there so I really don't want to reformat the partition and wipe everything. What is the next step to try to recover so I have working 13.04 (or failing that working 12.10)?

Over here was a suggestion to try

e2fsck -C0 -p -f -v /dev/sda1

but I get a message that this is in use. I tried to continue anyway and type in

apt-get -f dist-upgrade

but got the following message(s):

W: Not using locking for read only lock file /var/lib/dpkg/lock
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem

Being a sucker for instructions I tried

dpkg --configure -a

and got this error:

dpkg: error: unable to access dpkg status area: Read-only file system

What's my next step?

Update So, I booted from an install USB and did "Try Ubuntu", and am running GParted. I selected the Linux partition (ext4 with 22 out of 120 Gig in use) and clicked on "Check". It's been "checking" for 4 hours now - how long is this supposed to take? Or does "1 operation pending" mean it didn't even start checking yet?

Another Update Oh FFS! It sits there pending till you press the check mark? Grrrr...

share|improve this question

1 Answer 1

up vote 1 down vote accepted

OK, panic over. After I did the GParted check (and clicked on the check button) it took a couple of minutes to check and found no problems. Rebooting gave me the same errors as before. So using the installation USB stick I went into "Try Ubuntu" and then clicked on the Install Ubuntu icon.

I followed the installation (it's simple as you know) until the point where it asked whether I wanted to erase, install alongside or do something else. I clicked "Something else". I found my Ubuntu partition (which was actually discovered as being 13.04, so I guess the upgrade must have been mostly done) and adjusted it so that it had the mount point "/" - but DID NOT check the format box, prayed for a moment and pressed "continue".

The installation I think goes much faster from a USB stick than a DVD, and the longest step was about 10 minutes at the end when it said something like "updating previously installed packages".

Sure enough my Ubuntu is back with my customizations and installed apps all here. Hooray! The day is saved.

Now all I need to do is get into Win7 and run EasyBCD to set up the boot so my kids stay in Win7...

Hope this helps someone - you CAN reinstall Ubuntu without wiping your stuff, even if you don't have a separate /home partition.

share|improve this answer
    
Thanks, you are a genius, we had the same problem after Ubuntu pushed us a distro upgrade that broke the OS. Your method unfortunately reinstalls the system (/etc, /lib, /usr, /var, ...) which is slow but user files remain intact. –  Gabor May 5 '13 at 20:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.