Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need your opinion on this, any idea welcomed: I have a PC with separated / and /home FSs.
The root fs has ext4 on sda5, Ubuntu is Precise Pangolin LTS 3.2.0-40-generic-pae.

I had a package update problem saying the disk was full.
Hence dpkg --configure -a couldn't work.
Checked with df -h / and said 7.6G used 2.3G free.
I went down to runlevel 1 and remounted to read only the root fs.
mount -o ro,remount /

Then checked the root fsck /dev/sda5

No problem, so I checked with fsck.ext4 -c /dev/sda5, went through all OK 0.1% non-cont.

rebooted in maintenance mode, checked df -h / , same result: 2.3G free, could not touch /tmp/test, disk was rw, but full.
Running maintenance fsck did not change anything either.
So I rebooted again, mounted the disk read only again and run badsector -nf -t 0xaa /dev/sda5 with no error at all.
I checked, disk was still full, could not touch /tmp/test, df -h / shown 2.3G free space. Deleted the whole /tmp, old files from /var/log, aptitude autoclean and had got 2.5G free, so +200M freed up.
I ran again dpkg --configure -a , voila, started, kernel 3.2.0-40 was configuring, then after a while again, started to throw errors, disk was full.
Returned with error, checked df -h / 2.3G free.

I have no clue what's going on here, I'll try tomorrow from a usb Ubuntu boot disk the disk tests and a Dell utility hardware test, but I doubt any issue as neither badsector nor fsck had any problem.

If you could have any point of view, idea or magic, more than welcomed.

Many Thanks
Alex

share|improve this question
    
could you post the output of df -i –  max Apr 27 '13 at 22:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.