Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

What am I trying to do?

I am attempting to add a USB device to show up in Windows 7 in VirtualBox.

What is the problem and what have I done?

I've had to jump through a number of hoops to get this to work. In order for my software (Gearbox Installer) to work properly, I had download VirtualBox and used an ISO image of Windows 7 Professional (32-bit).

It took me until I could not add a USB port in the VirtualBox UI to realize that the software and hardware did not install properly (I did restart my computer after running the directions for installing this software). I followed all of these steps up until I reached the final step...

The checkboxes for "Enable USB Controller" and "Enable USB 2.0 (EHCI) Controller" are greyed out, "Enable USB Controller" is check marked by default, and no device appears upon clicking the USB+ sign.

Long story short...

I don't know if the software installed properly since I cannot add a USB port in VirtualBox. However, after plugging in the Toneport interface, the green light came on indicating it was operating properly.

share|improve this question

marked as duplicate by Mitch, Luis Alvarado Apr 28 '13 at 15:06

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

up vote 2 down vote accepted

You need to install virtualbox guestadditions in virtualbox. You can download the ISO from here (select appropriate version of virtualbox, and download the guest additions ISO).

Install the guest additions in virtualbox VM.

Then refer this question, to add yourself to vboxusers group.

This should solve the problem.

share|improve this answer
    
How exactly do I install guest additions in VirtualBox VM? I've read through the instructions here and I'm not sure what to do at the second step of Installing the Linux Guest Additions. –  Rob Apr 27 '13 at 23:17
    
You need to select some option from the menu of VM (the one that we get by pressing ctrl + home). I don't have a VM with me right now to see where this option is, but I am 100% sure that its right there in clear words "install guest additions" in one of the menus. Dont search for it in the virtualbox menus, but search in the VM menu (I hope I am clear on this). I hope this helps. –  bkd.online Apr 27 '13 at 23:47
    
There wasn't an "install guest additions" in my version (4.2.12), but I was able to get USB support. Thank you for your help! +1 –  Rob Apr 28 '13 at 0:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.