Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Computer Details: Toshiba, natively runs Windows7 64-bit. I currently dual-boot Windows 7 / Linux and have a virtual hard drive of Windows 8 (rarely used)

Background: I have been using Ubuntu 12.04 for a month now, with moderate difficulty. After installing all the recommended updates using the update manager on April 26th 2013, I shut down my computer. The next day instead of getting to the usual linux boot loader, I get a terminal-looking screen with grub that I have never seen before.

What usually happens when I boot: I get a list of three options (Windows 8 / Windows 7 / Ubuntu). I would select Ubuntu and it would load another list of options (Linux generic / Linux generic recovery mode / previous installations of linux/ linux generic development mode / linux development recovery mode). I would select the first option and it would bring me to the log-in screen.

What happens now after the update: I would load Ubuntu in the first menu, and instead of going to the second menu it will load a black screen with white text with the header "GNU GRUB version 1.99-21ubuntu3.9" and the subheading "Minimal BASH-like editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device or file completions." It will prompt me for commands in grub>

What I have tried: I have no idea what this all means, but I have tried some of the suggestions in http://ubuntuforums.org/showthread.php?t=2063281 (did not work because "linux vmlinuz root=/dev/sda1" is an invalid command and "(hd0,msdos1)/boot" did not return anything close to the expected output of "vmlinuz-3.2.0-xx-generic"). Similar threads do not have the same problems of me (they refer to Grub 2 or fresh installs)

Plea for help: Please teach me how to run Ubuntu from this grub loader (or how to restore it to the boot menu I had before). I am not very experienced in Linux so please be as explicit as possible in your instructions.

EDIT: I tried using the command "boot" from grub, but it gave the error "no loaded kernel"

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.