Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install sasl2-bin on Natty. However, it depends on db4.8-util, which could not be installed because the default package on Natty is db4.7-util. If I try to install the 4.8 version either from the deb package or from source, it gets deeper into the dependency tree, i.e. it requires more packages to be updated. I did try to manually update them all but at one point (after updating libc-bin) it said I needed to update openssh but that will break a LOT of things for me.

On the other hand, without sasl, I can't run postfix. Could someone please help me resolve this dependency issue?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

First do,

sudo apt-get install db4.8-util

and then

sudo apt-get install sasl2-bin

share|improve this answer
    
sorry I was being stupid. At first I couldn't run that command but that was because of something entirely unrelated... –  Lim H. Apr 27 '13 at 17:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.