Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

When I double-click the file, "start-tor-browser," the only thing that happens is a gedit window opens and displays a ton of programming code.

The program does not execute.

How to I make double-clicking "start-tor-browser" run my program, Tor Browser Bundle, instead of opening a gedit window?

share|improve this question

marked as duplicate by Alvar, karel, Aditya, BuZZ-dEE, Avinash Raj Feb 14 at 12:53

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2  
Follow the answers of this question: How do I run executable bash scripts in Nautilus?. –  Basharat Sialvi Apr 27 '13 at 16:28

6 Answers 6

up vote 6 down vote accepted

Nautilus is displaying your text file rather than executing the instructions in the text file.

Make sure the file is executable by <username>

ls -l <filename>

In the case of start-tor-browser, you should see:

-rwx------ 1 <username> <username> ...
  • For any other file, make sure that <username> has permission x

Make sure that Nautilus allows you to execute "Executable Text Files"

  1. Open Nautilus
  2. Edit > Preferences
  3. Check Ask each time under Executable Text Files under Behavior tab

screenshot

Execute the Executable Text File

Double-click your file and select Run if Ubuntu asks you how you want to execute the `start-tor-browser' script.

share|improve this answer
    
FIXED! This solved my problem. Thank you! –  Patrick Apr 29 '13 at 21:05

Give a right click at that start-tor-browser file and change at permissions as Execute the file as program and then try again .

share|improve this answer
1  
I checked "Allow executing file as program" and it did not work. The gedit window is still opening instead of Tor. I appreciate your reply. –  Patrick Apr 27 '13 at 19:13
    
@Patrick , Ok. Now open your terminal and execute the command as chmod +x start-tor-browser;./start-tor-browser by changing to the directory where you have placed the file. –  AgentCool Apr 28 '13 at 13:58
    
Thank you for the reply! –  Patrick Apr 29 '13 at 21:06

Find the path to the folder where the start-tor-browser is, and type cd /path/to/folder, then ./start-tor-browser.

share|improve this answer
    
Thank you for the reply! –  Patrick Apr 29 '13 at 21:07

I had the exact problem as yours.

I found this document extremely useful. Just follow all steps closely.

Even though it pertains to earlier version of Ubuntu, it works on my 13.04.

share|improve this answer
    
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Lucio Apr 28 '13 at 3:25
    
Thank you for the reply! –  Patrick Apr 29 '13 at 21:06

In my case it happened because I was trying to run it from a USB pendrive and the cause was that my entire drive did not have the permission to be executable. You can solve this problem by either changing the permissions of the drive or copying the folder to your home directory and it should run fine or after changing the file permissions

share|improve this answer

open ubuntu software center, search ibus, then uninstall

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.