Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

how to run uwsgi with python 3 instead of python 2? I've compiled the latest version of uwsgi, and i know there are plugins which can be installed by apt-get , but how can I get it(shall i compile it from source?)

share|improve this question

1 Answer 1

Please follow the steps provided here

http://uwsgi-docs.readthedocs.org/en/latest/Install.html

EDIT:

Or

1. sudo apt-get install python3-dev
2. sudo apt-get install python3-setuptools
3. which easy_install
4. sudo python3 <Output of which command> pip
5. sudo pip install uwsgi
share|improve this answer
    
is plugins/python support python3? I find out somewhere there's a plugin called python3.(written in a uwsgi ini file as plugins=python3) –  Bill Phun Apr 28 '13 at 1:18
    
Updated my answer with alternate method. Please check that. –  thefourtheye Apr 28 '13 at 1:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.