Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am fresh new to Kubuntu.

I was looking a way to move focused window as Windows do (Win key + arrow keys change the layout of the window). I found there are options for this in "Global Keyboard Shortcuts" (in KWin tab). Unfortunately, it seems to not work.

For example, "Move Window Down" is "Meta+Down". I believe the "Meta" key is the Window key on my keyboard, and "Down" the down arrow key. But it does nothing. Even if I change the key for Ctrl+Shift+K (I apply the settings each time).

Is the feature broken? Is there another way to do it in Kubuntu (without installing another software).

My Kubuntu version is 13.04 and my keyboard a Logitech k350 (I also tried with the virtual keyboard Kvkbd without any luck).

share|improve this question
add comment

3 Answers

up vote 0 down vote accepted

I have similar issue after upgrading to KDE 4.10.2. I'm not sure what's the cause, try this workaround:

  setxkbmap us

Where "us" would be the short name of layout. In case your're using more variants you can specify it as an extra argument:

   setxkbmap cz -variant "qwerty"

To check possible options see:

   man xkeyboard-config

EDIT:

Creating a fresh new user account solved that issue for me. I've tried before that

   mv ~/.kde ~/.kde-tmp
   rm -rf /var/tmp/kdecache-{username}
   rm ~/.ICEauthority
   sudo cp /home/new_account/.Xauthority /home/user/.Xauthority
   chown user .Xauthority

none of that helps. In my case the problem was also that I wasn't able to display System Settings > Startup and Shutdown > Service manager. Obviously some crucial part of KDE crashed and many dependent services stopped working.

share|improve this answer
add comment

The only possible explanation is that it conflicts some other keys.
Either application-specific, or global ones.

You need to look up the hotkey list if there is anything that grabs your hotkey from the function you want to call. (This happened to me many times in Konsole where Kopete grabbed my shortcuts.)

share|improve this answer
add comment

Actually it was my mistake. The shortcut names start by "Quick Tile Window to..."!

Now there is another problem. I cannot register the numpad keys as shortchuts (numpad1 is interpreted as 1). But it seems to be a bug running on KDE since a while. I will survive until it is natively supported.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.