Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Toshiba Satellite R830 laptop with Ubuntu 13.04.1 64 bit. The Fn + F6 and Fn + F7 buttons adjust brightness until I put my laptop on sleep.

On wakeup they don't work any longer.

On Ubuntu 12.04 and 12.10 I had the same issue but I solved it by modifying the GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

This is no longer working on 13.04.

I noticed that before I put my laptop on sleep I can change the brightness by manually changing the value of the /sys/class/backlight/toshiba/brightness file with the echo 4 | sudo tee /sys/class/backlight/toshiba/brightness command. Values are 0 to 7.

I can also change the brightness manually by using the echo 400 | sudo tee /sys/class/backlight/intel_backlight/brightness command. Values are much higher. I don't know the maximum or minimum, but setting it to 300 is very low and 4000 is very high.

After I put my laptop on sleep and wake it up again, the latter continue to work but not the former. It seems the shortcut keys and brightness control settings are bound to the ../toshiba/brightness value.

Is there a way to go solve this problem by pointing the shortcut keys to the ../intel_backlight/brightness value? or in some other way?

I would like to avoid using an old kernel if possible.

share|improve this question

1 Answer 1

have you tried using xbacklight

sudo apt-get install xbacklight
# increase brightness
xbacklight -inc
# decrease brightness
xbacklight -dec

(edit: since you want to go below the normal min brightness use the script below)
if that does not work you can edit this script or control it manually:
http://pastebin.com/HzzHrS2g
be sure to read the commends at the top of the script
You will need to edit lines 5 through 7

share|improve this answer
1  
xbacklight doesn't work. –  To Do Apr 27 '13 at 14:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.