Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

"... I consistently get two login screens!

I enter credentials correctly and am immediately presented with a second login screen (no errors). Authenticating against the second screen completes a normal login to the Ubuntu desktop."

The above is a quotation from a problem reported on 7. May 2012 by Soren Mogensen. See User login cycles. I have the exact same problem, and was hoping that Soren might have received an answer which would enlighten others, but unfortunately Soren's problem was reported as part of an "answer" to another problem, and the only "solution" on that occasion was advice to create a new question.

I can login, I just have to present my credentials twice, so this is NOT a duplicate of any "unable to login" problem. My concern is that this looks like a classic phishing setup, where one of the two login screens is a fake designed to harvest my ID and password for some nefarious purpose. If Ubuntu has been susceptible to phishing attacks for nearly a year now, then I imagine that would be a matter of enormous concern.

share|improve this question
Here a bug that could be related – Postadelmaga Apr 24 at 2:54

Uninstall your gnome-screensaver,

sudo apt-get remove gnome-screensaver

Then, reboot. It works for me, now only unity login screen appears.

share|improve this answer
this worked for me on 16.04 – Postadelmaga May 11 at 1:40
Worked for me on 14.04. Don't forget to restart! I had to force a reboot. – wjandrea Jul 4 at 19:03
  1. Try sudo pstree

    You should look for the Xorg process and see what parent it has. Is that parent process lightdm?

    Then you're using the LightDM display manager, and it's proboably a LightDM issue.

  2. Install another display manager, GDM

    sudo apt-get install gdm

    During configuration of the package, set GDM as the display manager.

    Does the problem still exist? Now you're sure it's a LightDM issue.

  3. sudo dpkg-reconfigure lightdm

    Now LigthDM is back.

share|improve this answer
Thanks. The parent process of Xorg was KDM. I switched to lightdm, got the message Please be sure to run "dpkg --configure lighttdm", so I did that (with sudo) and got the message. – MTGradwell May 5 '13 at 18:23
Thanks. I'm trying to post a multi-paragraph response here, but every time I press return it seems to post my message instead of starting a new paragraph. Anyway, the parent process of Xorg was KDM. I installed and switched to lightdm, and got the message 'Please be sure to run "dpkg --configure lighttdm"', so I did that (with sudo) and got messages 'package lightdm is already installed and configured' and 'errors were encountered while processing: lightdm'. The system now hangs on reboot, so I'm working on rebooting without the GUI in order to then get things back the way they were before. – MTGradwell May 5 '13 at 18:48
Now I've got it booting again and set GDM as the display manager. I still get two login screens in succession but they look different now, and are accompanied by a musical note. – MTGradwell May 5 '13 at 19:06
Getting weirder. I've switched to lightdm again and this time it doesn't hang, but now it boots straight to the desktop. I'm able to use the desktop for a minute or two, and only THEN does a login screen appear. – MTGradwell May 5 '13 at 19:36
Finally I've switched the display manager back to KDM, which is what it was originally. I still get two login screens, one after the other, but since the alternative display managers seem to be as bad or worse, I think I'll leave well alone. Thanks anyway for the help. – MTGradwell May 5 '13 at 19:46

This solution seems to work for some as it looks like an ongoing problem depending on circumstances - Look in your system settings for "Lock Screen" in all possible applications.

  1. Search dash or in system settings go to " Brightness & Lock " then turn lock off.

  2. Check in other apps like Unity Tweak Tool -> System and uncheck " Desktop lock ".

  3. Open a terminal and navigate to /var/log/ then use " sudo gedit auth.log " and check the log then check to see what happens at start if there any errors. Lookout for pam-wallet issues like directory not found, error opening it. If you see wallet errors then try reinstall - sudo apt-get install pam-kwallet" then "echo "Cleaning Up" && sudo apt-get -f install && sudo apt-get autoremove && sudo apt-get -y autoclean && sudo apt-get -y clean" finally "sudo apt-get update". Reboot machine.

  4. Reconfigure lightdm using - commands below one by one

sudo apt-get purge lightdm, sudo apt-get install, sudo apt-get install lightdm, sudo dpkg-reconfigure gdm,

Hope it helps someone.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.