Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu 10.10 Server x64 installed as Virtual Box VM.

Fresh install plus postgresql and tomcat6 installed via aptitude. Rebooted the server and now when I run some command the console hangs. For instance, I run "sudo shutdown now" and then nothing happens but I am not returned to the prompt. I hit CTRL+C and nothing happens except ^C appears on the following line. I can type whatever and it will show up inline.

I switch to tty2 and try to login and I only get as far as [username][enter] and that console hangs.

One other thing - after "sudo reboot" the console appears to hang (just like above) when shutting down tomcat6.

Any idea what's going on or what I should check?

Thanks!

share|improve this question
    
Have you modified ~/.profile or ~/.bashrc ? –  geirha Mar 2 '11 at 2:47
    
No, I haven't manually modified any config files. Just the two installs I mentioned. Thanks. –  Josh M. Mar 2 '11 at 2:51
    
during your install did you specify partitions to be mounted that are no longer present? –  M. Tibbits Mar 2 '11 at 2:54
    
No I didn't, I used auto/guided mode. I've just removed the web app that was deployed to tomcat6 and performances seems to be back to normal. So that narrows it down! –  Josh M. Mar 2 '11 at 3:00
    
If that is the solution you might want to post it as an answer to your won question. –  Octavian Damiean Mar 2 '11 at 10:50

1 Answer 1

The problem turned out to be the DHIS2 WAR I had deployed to the tomcat6 installation. Stopping tomcat6 and removing the WAR and the directory and then rebooting has fixed the problem. I haven't diagnosed farther than that yet.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.