Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just did a clean install of 13.04 and now cant open any hard disks or hard disk partitions, it says "permission denied". I can open them as root but when I try and change the permissions it says I already have full read and write privileges and wont change the options for group or other users permissions.

The drives are NTFS format, for windows compatibility,while I can get in as root it is a major hassle as all my data is on the second hard drive and I cant add music or video to media players or open text documents without using root.

I know similar question have been asked before and I have tried many solutions but with no luck.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted
sudo mount -t ntfs -o uid=<your user id>,gid=<Your group id> <HDD Device Name> <Target Folder to Mount>

You can get your user id and group id from /etc/passwd file. This is how my user's entry looks like in my /etc/passwd file. First 1000 is my UID and the second 1000 is my GID.

thefourtheye:x:1000:1000:thefourtheye,,,:/home/thefourtheye:/bin/bash

If you dont want to execute the mount command each and every time you boot up, just add that command in /etc/rc.local file.

share|improve this answer
    
Thanks mate worked a treat :) –  mark kirby Apr 27 '13 at 12:36
    
You are welcome :) –  thefourtheye Apr 27 '13 at 13:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.