Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

In Windows Vista I can switch off via power management: PCI Express Modem port Optical DVD drive

Via network connection I disable: Blutooth

How can I do similar in Lubuntu? Under Power Manager I don't have the options.

It would be good to have a GUI manager for this.

share|improve this question

marked as duplicate by Mitch, Luis Alvarado Apr 28 '13 at 15:07

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
there is no gui tools ...for power management –  Qasim Apr 27 '13 at 9:48
    
But my question title is better for noobs :P ? –  user127379 Apr 27 '13 at 11:59

1 Answer 1

Improve Power Usage / Battery Life In Linux With TLP, I been using TLP from 3 to 4 weeks and My laptop is running 4 to 5 Deg cooler than windows 7/8, so here the tlp installation and configuration

 sudo add-apt-repository ppa:linrunner/tlp
 sudo apt-get update
 sudo apt-get install tlp tlp-rdw smartmontools ethtool

Configuration

 sudo update-rc.d -f ondemand remove 

The main config file of TLP is at /etc/default/tlp

  sudo gedit /etc/default/tlp

Go to cpu frequency Section and and uncomment the following lines add the following config.

CPU_SCALING_GOVERNOR_ON_AC=conservative
CPU_SCALING_GOVERNOR_ON_BAT=conservative

Next Section Set the cpu "turbo boost", uncomment if commented

 CPU_BOOST_ON_AC=1
 CPU_BOOST_ON_BAT=0

Next Section Radeon graphics clock speed, comment it if you not using Radeon graphics

 #RADEON_POWER_PROFILE_ON_AC=high
 #RADEON_POWER_PROFILE_ON_BAT=low

Next Section optical drive

 BAY_POWEROFF_ON_BAT=1

Next Section PM for all pci(e) bus devices, Warning: experimental option, could cause system instabilities..But i found no problem just you have to put usb 2 devices in usb 2 port and usb 3 devices in usb 3 port

 RUNTIME_PM_ALL=1

Some times my usb mouse dongle didn't work when i plug it in usb 3 port, work fine when i plug it in usb 2 port, and all my usb 3 devices are working properly no issue.

Save & Exit

You can also configure Devices to Disable on startup etc, there is very good help in config file.

I have an error that my Blue tooth device is not Disabled on start up, so if you face this problem just do the following config

 sudo nano /etc/rc.local 

And add the following line before exit 0

 rfkill block bluetooth

Save & Exit & Reboot

Optional

Install indicator-cpufreq that help you alot Changing freq

 sudo apt-get install indicator-cpufreq 

Go to Dash > search startup > edit indicator-cpufreq add -f or copy paste the following command

 indicator-cpufreq -f 

enter image description here

enter image description here

this will let you see what Freq you are running.

Done

Optional

PowerSavingTweaks Intel Graphics

 sudo nano /etc/default/grub

change:

 GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" 

to:

 GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.lvds_downclock=1 drm.vblankoffdelay=1"

and run:

 sudo update-grub

Done Reboot

You do not need other tweaks as they are already added by defaults.

Check you TLP Stat

 sudo tlp-stat

Check You System temperature

 sudo tlp-stat -t

There is very good help at TLP Website

Useful Config Link 1

TLP Settings

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.