Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Two days ago my new Thinkpad X1 Carbon arrived. It reportedly has "up to 8.2 hours of battery life".

I installed 13.04 Raring Ringtail (x64) on it a day after it was released, and then gnome-shell.

Now, with wireless, mobile internet and bluetooth all turned off, and screen brightness reduced, it reported 3 hours of batter life at 100%, and given how quickly it's decreasing that seems to be accurate.

Results I got from googling:

  • No-one on this forum question mentioned issues with battery life...
  • someone suggested that Ubuntu might not manage the fan properly (although I haven't noticed excessive noise) so I installed thinkfan including running sensors-detect as suggested under "troubleshooting".
  • some else recommended some special grub boot options, but I didn't understand them and in the comments someone suggested they might no longer be necessary

I'm going to try rebooting into Windows now to see if it performs better. If it doesn't I'll contact Lenovo support and call it a hardware issue - and of course update this question.

share|improve this question

marked as duplicate by Mitch, user68186, Luis Alvarado Apr 29 '13 at 21:26

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Interesting suggestion, but I don't think that's the perfect solution. There are other answers here like @RobbieW's which are semi Thinkpad specific –  Robin Winslow Apr 29 '13 at 17:11

2 Answers 2

up vote 2 down vote accepted

I have a Lenovo X1 and battery life is MUCH longer than 3 hours with Raring. I also make sure I reduce my screen brightness when on battery, and have the following entries in /etc/modprobe.d/powersaving.conf:

    options i915 i915_enable_rc6=7
    options i915 i915_enable_fbc=1
    options i915 lvds_downclock=1

I had these with 12.10 and they seemed to help. I would also recommend installing powertop, and then running it occasionally to see if you have any rogue processes sucking up power.

share|improve this answer
    
I did this, and included some other tweaks from wiki.ubuntu.com/Kernel/PowerManagement/PowerSavingTweaks. If I reduce screen brightness and turn off everything now I can sometimes get 8 hours –  Robin Winslow May 1 '13 at 8:26

You could install the package laptop-mode-tools It helps quite a bit for me to save power, althought it can sometimes try to save power a bit too aggressively like powering down the usb port when your usb mouse is being used.

You can also try ubuntu 12.04LTS on a livecd, see what sort of estimate you get on there. 12.04 is quite good on battery on my laptop. 12.10 was terrible in terms of battery live for me. Sometimes its release specific. Try 12.04 out, maybe its just 13.04 specifically although I doubt thats the case. Could be thought.

You can also use powertop and powertop-1.13 from the terminal to see what devices are active and which are in powersaving mode.

I highly doubt that the fans are running for no reason. You can check their temperature using acpi -t (if your hardware supports it) in a terminal or psensor temperature indicator.

For some reason or other some powersave features had been disabled in 12.10, those in grub kernel parameters in the article you linked to enable them. Personally I use them. Althought ubuntu 13.04 probably has them enabled by default already. See: https://wiki.ubuntu.com/Kernel/PowerManagement/PowerSavingTweaks

So in the end, theres probably not much you can do other than try a different release or try track down what it is that is eating power and fix it.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.