Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It competes with the Alt behavior in Photoshop, so I want the left Alt key to do nothing.

share|improve this question
    
I don't exactly can figure out how this behaviour can compete with the ALT behaviour in photoshop, but if you could install Photoshop under wine I would appreciate if you point me to a place where to find a how to. If you are using Photoshop in a virtual machine (Virtualbox) you may be interested in the "Seamless mode" which may help you to fix this issue. –  Geppettvs D'Constanzo Mar 1 '11 at 23:11
    
I installed Photoshop using "Play On Linux" and it works fine. The alt key is used in Photoshop to duplicate a selection. Quite handy. –  Gizmoatwork Mar 2 '11 at 3:32
    
Gimp and inkscape also use the Alt key for things –  user1477 Oct 2 '11 at 5:06

3 Answers 3

up vote 8 down vote accepted

You can change it from Alt to Super and vice-versa. Go to System ➜ Preferences ➜ Windows and in the Windows Preferences Choose which "Movement Key" you wish to use.

A screenshot to illustrate is placed here:

enter image description here

Additionally, if you are using compiz, you can change which key bindings you wish to use in order to "Initiate Window Move" when the "Enable Move Window" plugin is in use.

Here is a screenshot to illustrate what I say in the above words:

enter image description here

share|improve this answer
    
Thank you very much. The "ALT" to "SUPER" trick works perfectly ! –  Gizmoatwork Mar 2 '11 at 3:33

Alternatively you can press Alt+Win in Photoshop. I have tried this in Photoshop under VirtualBox machine.

share|improve this answer

You can also change the X key from command line (Terminal):

Gnome 2 (Ubuntu 11.10)

sudo apt-get install -y gconf2
gconftool-2 -t str --set /apps/metacity/general/mouse_button_modifier '<Super>'

Gnome 3 (Ubuntu 13.04)

sudo apt-get install -y libglib2.0-bin
gsettings set org.gnome.desktop.wm.preferences mouse-button-modifier '<Super>'
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.