Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install Ubuntu Gnome 13.04 in VirtualBox (4.2.12) on a Windows host.

Initial installation works but after installing Guest Additions, VirtualBox always crashes during login.

I tried to install Gueset Additions via the additonal driver menu and compiling it from the VirtualBox provided ISO. Same problem.

I also tried to install Lubuntu 13.04 and install gnome shell via apt. Same problem.

32 or 64bit version. Same problem.

I also tried the previous version of VirtualBox. Same probleme.

Tried to install gnome 3.8 from ppa. Same problem.

How can I use Ubuntu Gnome 13.04 in VirtualBox?

update: I unchecked the 3D accaleration option in the VM settings. VirtualBox no longer crashes but I keep getting a dialog box saying that a system application failed the error reporting preview says:

  • ExcecutablePath: usr/bin/gnome-shell
  • ProblemType: crash
  • Title: gnome-shell crashed with SIGSEGV
share|improve this question

1 Answer 1

We do successfully run Ubuntu GNOME remix 13.04 64-bit in Virtual Box 4.2.12 on an Ubuntu 12.04 64-bit host.

For stability we may have to update our Ubuntu OS by booting into a root shell and run:

apt-get update
apt-get dist-upgrade

We did experience occasional crashes from the default wallpaper, which can be replaced by a static wallpaper running:

gsettings gsettings set org.gnome.desktop.background "file:///usr/share/backgrounds/gnome/FootFall.png"

If we can not log in to the grpahical desktop we can log in to TTY by pressing HOST + F1.

We may also remove the Guest Additions to change settings in the GUI.

share|improve this answer
    
The install is from yesterdays release so dist-upgrade does nothing. –  wierob Apr 27 '13 at 9:04
    
There is plenty of reasons for this from unfixed bugs in a new relase (hence recommends for updates in root shell) to incompatibilies from the virtualbox graphics driver with the host graphics... hard to say where your issue may be. How's your guest graphic card settings? –  Takkat Apr 27 '13 at 9:11
    
128 MB, 3D enabled –  wierob Apr 27 '13 at 9:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.