Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For some weeks I was unable to use Ubuntu due to Windows 8 preventing its boot, so I noticed an interesting function that I missed in Ubuntu:

In Windows 8 when I plug-in my headphones I was able to open the mixer options and set the speakers to reproduce the audio, even with the headphones plugged and more than that I was able to handle my skype conversations through the headphone while listening to my music, or youtube videos, or games in the speakers.

Although in Ubuntu when I go "Sound Settings..." > "Output" I was unable to redirect the audio to the speakers while the headphone was connected. I have three options: Digital Output (S/PDIF) Built-In Audio; Analog Output Built-In Audio; and Analog Headphone Output Built-In Audio. When I choose Digital I have no audio at all, in any situation. Although it doesn't matter if I choose Analog or Analog Headphone the audio will be headed to the headphone.

Then I noticed that it was a problem: I am not able to use the speakers while my headphones are connected, the main point here is not to separate audio from skype, from the other things, I guess (and hope) that it can be easily set in skype settings once the main problem is fixed: set the speakers as primary reproduction devices even when my headphones are plugged in.

share|improve this question
add comment

1 Answer

edit /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf

And in section [element speakers], try to change switch=on into switch=off

share|improve this answer
    
It didn't work, switch is already off, although I tried setting to on, then restarting the PC and nothing changes, also tried changin' [Element Headphones], [Element Headphones 2] [Element Desktop Speakers] and nothing changed... –  Rodrigo Martins Sep 5 '13 at 15:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.