Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use Ubuntu (Spanish language). Sometimes I get this error when I use special characters (codification error) so I read that if I edit a file of my hard disk by using gedit /etc/fstab and adding utf8 I can fix it....

I had this line:

UUID=bfb5b95e-bf68-464a-8abf-d6027b039fa4 / ext4 errors=remount-ro 0 1

I adeed utf8 like this:

UUID=bfb5b95e-bf68-464a-8abf-d6027b039fa4 / ext4 errors=remount-ro,iocharset=utf8 0 1

But I messed my Ubuntu and I can't log in now to my Ubuntu so im using live session... so I'll have to remove that code in order to be able to use my Ubuntu again. Can someone tell me how that line should look like?

share|improve this question

1 Answer 1

With ext4 (or ext3/2) you don't have to specify character set for filesystem. It does not care, as long as you are not using unescaped control characters in filenames.

Your system locale is more important thing. Try dpkg-reconfigure locales and select appropriate UTF-8 locale. Also, if you are using virtual terminal, make sure you have UTF-8 enabled (for example in GNOME Terminal: Terminal->Set Character Encoding).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.