Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Xubuntu 13.04 on a new Dell XPS 13 Ultrabook. When I boot up the screen brightness is EXTREMELY dim. Adjusting the screen brightness doesn't do anything. This is obviously a very new bug with 13.04.

Any ideas?

share|improve this question
add comment

2 Answers 2

here are a couple kernel boot parameters you can try

  • acpi_osi=Linux
  • acpi_backlight=vendor
  • acpi_osi='!Windows 2012'


This is there you add that code, I had to use the 3ed one to get mine working right, it may be necessary to use 1 or 3 combined with the second one
The file to edit is :
/etc/default/grub
once you edit it run sudo update-grub then reboot

share|improve this answer
    
never ever seen acpi_osi='!Windows 2012' ... –  Qasim Apr 27 '13 at 3:33
    
i got it from a kernel dev here –  GM-Script-Writer-62850 Apr 27 '13 at 3:44
    
i did google ...ty for updating the information... –  Qasim Apr 27 '13 at 3:45
add comment

Along with @GM-Script-Writer-62850's answer, if you're using an EFI BIOS boot, you ned to go into the BIOS setup and set "Load Legacy Rom" to Enabled.

I have experimented with the minimal GRUB line to get this working and I only need acpi_osi=Linux

AFAIK Legacy is anything not Windows 8, and I've not experienced any performance hit.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.