Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After I updated to 13.04, Ubuntu immediately shuts down without confirmation when I press the power button. Also, it doesn't ask for confirmation if I select an otion from the top-right gear menu. I tried setting the flag org.gnome.gnome-session.logout-prompt to true in dconf-editor and I set the power button action to "Interactive" in Tweak Tool.

share|improve this question
    
Temporarily you can use sudo shutdown -r to "restart" given that there's no direct menu option for it. –  Brandon Bertelsen Apr 27 '13 at 1:58
    
There is a menu option for it, but no confirmation dialog and the power button always shuts down my machine, regardless of the actual setting. –  Donarsson Apr 27 '13 at 2:45
    
This might be a bug. Hard to know anything or even do background research without knowing more about the laptop. (Manu? Product code? System specs?) –  Brandon Bertelsen Apr 27 '13 at 2:48
    
It can't be the hardware, because it worked until I upgraded and also the shutdown procedure should only start after a confirmation, which has nothing to do with hardware. –  Donarsson May 2 '13 at 9:39
    
You misunderstood, I'm not saying it's your hardware, I'm saying it might be a software problem specifically related to your hardware. –  Brandon Bertelsen May 3 '13 at 14:00
show 2 more comments

2 Answers

up vote 3 down vote accepted

I finally found the solution! Apparently the setting of /org/gnome/gnome-session/logout-prompt is ignored in newer Ubuntu versions, the right key was /apps/indicator-session/suppress-logout-restart-shutdown. So to fix this, do dconf write /apps/indicator-session/suppress-logout-restart-shutdown false in terminal. It should take effect immediately without restart. It seems that sometimes this value is set to „true“ by upgrade or third party applications.

share|improve this answer
add comment

In ubuntu 13.04 i find this is working, so please open a terminal and type or better copy and paste the row below then press enter:

dconf write /org/gnome/gnome-session/logout-prompt false
share|improve this answer
    
Not only is this question already solved, but you suggested tampering with the exact setting that was found out to not work anymore in 13.04 and if it would, your suggestion would do the exact opposite of what I wanted. –  Donarsson Aug 25 '13 at 18:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.