Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I open sortware update application I am not seeing any notification about a new release. So I tried to manually upgrade by running

sudo apt-get update
sudo do-release-upgrade

and I am getting this error:

Checking for a new Ubuntu release
Traceback (most recent call last):
File "/usr/bin/do-release-upgrade", line 145, in <module>
fetcher.run_options += ["--mode=%s" % options.mode,
AttributeError: type object 'DistUpgradeFetcherCore' has no attribute 'run_options'

How do I upgrade to 13.04?

share|improve this question

1 Answer 1

It's a known and solved bug, reported here:

https://bugs.launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+bug/1076186

You should now be able to upgrade by running:

sudo apt-get update
sudo apt-get upgrade
share|improve this answer
    
Is there anything affected users can do to resolve the problem? Does it just work now? –  djeikyb Jun 11 '13 at 6:52
    
It should work after running sudo apt-get update && sudo apt-get upgrade –  grimpitch Jun 17 '13 at 4:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.